Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Lenovo e530 turns on, cooling fan turns off,no display. (Resolved).


Best Answer EmishOrc , 28 May 2016 - 07:46 AM

I went through the update and it was a sucess! Installed 8.1, monitored temps and temps were perfect. Fan purrs like a cat. The error only stated that the laptop needed to be charged to avoid error... Go to the full post »


  • Please log in to reply

#1
EmishOrc

EmishOrc

    Member

  • Member
  • PipPipPip
  • 149 posts

Hello again,

I have a Lenovo e530 that a person gave to me for nothing so im kinda lucky that I got a powerful laptop for nothing :)

But it comes with some problems. The guy told me it had some water damage. I had an inspection at it cleaned everything applied new thermal paste. And it turns on!, but it doesn't display anything at all and upon further inspection I found that the cooling fan turns on then off.


Edited by EmishOrc, 28 May 2016 - 02:24 AM.

  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,000 posts

Hello EmishOrc,

 

Possible signs that something has shorted/burned out.

 

Try pulling the RAM and powering up the notebook to see if you get any error beeps.

 

No display (if this includes no BIOS screen) and the CPU cooling fan not working properly makes a fried CPU a strong contender as the culprit I`m afraid  :(


  • 0

#3
EmishOrc

EmishOrc

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts

I shall get back to that soon.


  • 0

#4
EmishOrc

EmishOrc

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts

Update: It's alive! It Posted! Before I continue it said real time clock error please check date and time what does that mean?


Edited by EmishOrc, 28 May 2016 - 05:28 AM.

  • 0

#5
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,000 posts

You need to set the time and date in the BIOS, if it gives the same error on next cold start the CMOS battery may need replacing.


  • 0

#6
EmishOrc

EmishOrc

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts

Some say that this could be a bios bug that does this to this model. The fan retains velocity, but same problem. Ill try BIOS update and report back, because it throws an error saying it needs the laptop to be charged.


  • 0

#7
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,000 posts

Updating the BIOS is always a last resort as a bad flash can render a computer useless.

 

Some say that this could be a bios bug that does this to this model.

 

 

To what problem are you referring, the RTC error or fan speed.

 

Where do you get the battery needs charging message and what does it say exactly.


  • 0

#8
EmishOrc

EmishOrc

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
✓  Best Answer

I went through the update and it was a sucess! Installed 8.1, monitored temps and temps were perfect. Fan purrs like a cat. The error only stated that the laptop needed to be charged to avoid errors. Oh and I replaced the RAM stick, tested keyboard and now im updating drivers...


  • 0

#9
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,000 posts

Good job  :thumbsup:

 

Oh and I replaced the RAM stick

 

 

Did the original memory stick look damaged in any way, water damage causing corrosion etc.


  • 0

#10
EmishOrc

EmishOrc

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts
No, but I tested it on my other laptop and she's gone. So I managed to grab another DDR3 Ram stick to use in it. I will show this in action. I have attached a photo.
  • 0

Advertisements


#11
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,000 posts

No pic attached EmishOrc.

 

Did you forget to click on the Attach This File tab perhaps.


  • 0

#12
EmishOrc

EmishOrc

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts

That is it I swear my Samsung is giving me a hard time... Anyway here it is :)

 

http://imgur.com/nOYRmi1Sorry, but there is something wrong with this site I cannot upload anything even on PC.


Edited by EmishOrc, 29 May 2016 - 02:56 AM.

  • 0

#13
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,000 posts

Looks good for a computer that has had fluid damage, lucky you for being gifted it  :)

 

Not sure what is going on with your attachments, check your profile settings and if you have uploaded anything before make sure that you have not reached your upload limit, if you have, delete some of the uploads that you no longer feel are relevant.


  • 0

#14
EmishOrc

EmishOrc

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 149 posts

I will sure look at that.


  • 0

#15
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,000 posts

:thumbsup:


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP