Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

All browsers on windows 10 really slow. (Resolved).

- - - - -

Best Answer Marieukxx , 16 June 2016 - 06:10 AM

Still seems to be working a lot better now thanks. Do you mind if I start another topic in the XP forum. My dad's pc is on xp and there is a problems with it. I'll use that speccy and start a new t... Go to the full post »


  • Please log in to reply

#1
Marieukxx

Marieukxx

    Member

  • Member
  • PipPip
  • 73 posts

Hi guys,

 

I am hoping somebody can help with the problems I am having. I upgraded from windows 8.1 to 10 ages ago now. I actually prefer windows 10 to 8.1 so would like to keep it. I've had no problems until about a month ago when I noticed on my laptop only (our old pc running XP is fine) both of my browsers are very slow to load pages and sometimes they don't load and I have to click try again.

 

I assumed I may have a virus or something so I've run malwarebytes loads of times and it shows nothing. I've scanned with windows defender and nothing. I've run Superantispyware and that just showed up PUP things.

 

I googled and followed a tutorial to change the size of the virtual memory and that's made no difference.

 

Can anybody help please. I'm not a techy so easy instructions please lol. Oh I forgot to say the browsers are Firefox which I use the most and Chrome. Both are slow loading pages. Oh and the upgrade was through invitation and I checked the thingy that let you see if your system would be compatible with windows 10 and it said it was. And downloading is still fine and the same speeds I usually get. It's just pages take a while to load or I get an error if it takes to long to try again.


Edited by Marieukxx, 15 June 2016 - 08:15 AM.

  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 21,385 posts

Hello Marieukxx,

 

Possibly a security setting or browser plug in problem.

 

Download then run Speccy (free) and post the resultant url for us, details here,  this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s. 


  • 0

#3
Marieukxx

Marieukxx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 73 posts

Thanks for the reply. While I've been waiting I did change the network channel and now it seems a lot faster so far. I'm thinking that may have done it but I will post back the speccy stuff anyway just in case.


  • 0

#4
Marieukxx

Marieukxx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 73 posts

http://speccy.pirifo...PEGLQF3Lkd3gJHH


  • 0

#5
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 21,385 posts

Nothing showing in Speccy other than a few failed updates so you have hopefully managed to resolve this already.

 

See how it goes for a couple of days, if no further problems let us know and likewise if it happens again please let us know.

 

NB: I would suggest that you check for and install any important updates for Windows and Windows Defender.


  • 0

#6
Marieukxx

Marieukxx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 73 posts

Thanks. It still seems better now since changing the wireless channel. I checked or windows updates and defender updates te other day and it said they were up to date.


  • 0

#7
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 21,385 posts

Updates info acknowledged and thanks for the update Marieukxx  :thumbsup:


  • 0

#8
Marieukxx

Marieukxx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 73 posts
✓  Best Answer

Still seems to be working a lot better now thanks. Do you mind if I start another topic in the XP forum. My dad's pc is on xp and there is a problems with it. I'll use that speccy and start a new topic.

 

I think you can close this one. Pretty sure it's ok now.


Edited by Marieukxx, 16 June 2016 - 06:43 AM.

  • 0

#9
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 21,385 posts

No problem and thanks for the follow up  :thumbsup:


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP