Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Missing Drivers

Loading drivers

  • Please log in to reply

#1
WilliamP

WilliamP

    Member

  • Member
  • PipPipPip
  • 171 posts
I have a home built computer with an ASRock P67 Extreme 4 Gen3 mother board, Intel I7- 2700K processor,running Win. 7 64bit. It has USB 3 ports but I have never used them. Now I have a USB3 enclosure that I want to use. I checked in device manager and it looks like the drivers aren't loaded. I checked Device Manager because I had put the USB cable for my mouse in one of the USB 3 ports and it wouldn't do anything. What do I need to do to get it working?
  • 0

Advertisements


#2
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts

Hi,

 

Visit the ASRock web page: http://www.asrock.co...nload&os=Win764

 

Download and install the following drivers in the order:

  1. INF driver ver:9.2.0.1015
  2. Etron USB 3.0 driver ver:0.96_WHQL

  • 0

#3
WilliamP

WilliamP

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 171 posts
Thank you my friend.
  • 0

#4
WilliamP

WilliamP

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 171 posts
Seems like all is well. The first download and install ( the INF driver ) shifted the icons on the desk top around but I think all is ok.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP