Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

New Build 16gb memory installed- hardware reserved 7.99gb

- - - - -

  • Please log in to reply

#1
Reneh85

Reneh85

    New Member

  • Member
  • Pip
  • 7 posts
Hey all :)
Thought I'd try my luck here as I don't seem to be having much luck so far.
I've just upgraded my PC to the following parts
Mobo- GA 970a D3P
CPU- FX- 8320
Ram- HyperX fury 8gb X 2 kit
Gpu- Gigabyte Hd Radeon 7950

My problem is Memory atm, 16gb installed, BIOS, speccy, Cpuz and windows all recognised the 16gb but only 8gb was usuable and in single channel not dual channel. I tried most things people had suggested to try, virtual memory off, memory setting in advanced boot options, made sure all overclock settings were off, checked CPU pins ect, check each ram slot ect.
Changed the ram speed to 1600 instead of 1866 as I read that my mobo only supported 1866 per channel. Nothing worked. So I decided To do a clean reinstall of windows as I hadn't done that with my new parts yet. And to my surprise finally the full 16gb was usual with windows and showing Dual channel now.
Turned my PC on today and I'm now back to square one 😩 The only major update I've don't since my clean install was a update from windows last night - currently uninstalling this to see if that might help.
if anyone has any suggestions it would be most appreciative.
Cheers
Renee
  • 0

Advertisements


#2
TammyGarza

TammyGarza

    New Member

  • Member
  • Pip
  • 8 posts

32 bit OS got RAM limitation even some motherboard restricts it.

as you have not mentioned your OS version and whether it is 64 bit or 32 bit kindly enlight with further info so we can figure out the solution 

and if you plan to upgrade to the 64 bit make sure your CPU supports it (right click on my PC/computer then check your system type is 64 or 32)

 

Have  a Great day :)


  • 0

#3
Reneh85

Reneh85

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Lol [bleep] sorry was meant to put that it in. Yep 64bit. I just don't get it when I reinstalled windows yesterday it showed the full 16gb no hardware reserved. Then today back too 7.99 hardware reserved. I just tried my old gpu as I had read the gpu could be part of the "hardware reserved" but nope same problem. I thought it may have been my mobo- incompatible ram ect. But seeing as though all was well when I reinstalled windows something fishy is definitely going on.
Thankyou for your reply much appreciated :)
  • 0

#4
Reneh85

Reneh85

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Windows 10 pro edition. Sorry didn't think to add as I posted in the windows 10 section
  • 0

#5
FreeBooter

FreeBooter

    Member 1K

  • Member
  • PipPipPipPip
  • 1,340 posts

To see where the missing memory is ... Task Manager -> Performance tab -> Resource Monitor button -> Memory tab -> the bottom Window graphs allocation of physical memory.

Where available memory is substantially different than physical RAM installed it points to it being reserved by hardware devices (check integrated GPU shared memory allocation settings as the page buffer is removed from physical memory pool) and disable your DEP (data execution prevention) . DEP is primarily only effective against buffer over run exploits which the O/S memory manager already handles. As well buffer over run exploits are rare and effectively handled by sandboxing firewalls if you have one. DEP can reserve a huge whack of RAM that will not be part of the available RAM. How to disable DEP can be found here http://www.thewindow...ion...revention. Additionally, make sure you have a suitable page file setting.


  • 0

#6
Reneh85

Reneh85

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Thankyou very much for your reply.
The link provided page could not be found but I'll see if I can find how to disable DEP.
Sorry still a bit of a noob with the technical side of things.
Because the other 8gb is "hardware reserved" my ram is only being recognised as single channel. When I put each stick in different channels the 16gb will be accessible only as single channel obviously.
I think I changed the page file in regedit? Changed the value from 0 to 1? Not sure if it's what you suggested but I'll jump on the net and see what I come up with.
Thankyou very much 😀
  • 0

#7
Reneh85

Reneh85

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
I don't know if this is relevant but I was reading this problem could be because my Windows 10 version was the free upgraded version Microsoft was providing for upgrading from windows 7 few months back. Apparently there were restrictions on hardware upgrades ect. This problem seems so common. Anyways was just a thought.
Thanks again 😉
  • 0

#8
Reneh85

Reneh85

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Just turned off DEP and still problem persists 😩
How would I change the page file setting? Through regedit?
Thanks guys
  • 0

#9
Reneh85

Reneh85

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Just turned off DEP and still problem persists 😩
How would I change the page file setting? Through regedit? I did that yesterday change the value from "0" to "1"
  • 0

#10
FreeBooter

FreeBooter

    Member 1K

  • Member
  • PipPipPipPip
  • 1,340 posts

Page file has nothing to do with your issue. Boot your computer into BIOS setup utility and see if computer sharing the lose memory size with graphic card look for setting sharing memory for graphic usage. Sometimes disconnecting and reconnecting the RAM modules can resolve this kind of issue but before doing that make sure disconnect the power cable from the power supply unit and read my tutorial about preventing Electrostatic Discharge.


Edited by FreeBooter, 17 November 2016 - 07:14 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP