Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Is my power supply working properly?


  • Please log in to reply

#1
HrcaA3000

HrcaA3000

    Member

  • Member
  • PipPip
  • 14 posts
Hi,
 
Is this normal boot up?I mean when I press power button blue lights appear for one second and then they shutdown. After 2 seconds blue lights appear and then the system boots up.
Video is below:
 
http://sendvid.com/ao6m4oa7
 
I am using this power supply-
 
http://xfxforce.com/...ze-p1-600b-xtfr

Edited by HrcaA3000, 19 December 2016 - 12:36 PM.

  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 21,402 posts

Hello HrcaA3000,

 

Looks like the LEDs go out and back on as the MB goes through the POST procedure and therefore nothing to worry about.

 

NB: I would suggest a change of video upload site, I got to view your video content at the third attempt after twice being subjected to spammy videos offering me services that I neither wanted or appreciated  :(


  • 0

#3
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 21,402 posts

Not heard back from you HrcaA3000 , do you still require assistance or is the issue now resolved, an update would be appreciated.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP