Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

News Build


  • Please log in to reply

#1
Granthickey

Granthickey

    New Member

  • Member
  • Pip
  • 1 posts
I have a gigabyte Z170XP-SLI and a Corsair H100i v2 CPU cooler and a supernova 750 G2 power supply and GeForce GTX 1060, i5 intel CPU, Hyperx ram and I can not get it to power up...I checked the PSU and it works I have breadboarded everything and can not get anything I have check all connections and rechecked and still can not get anything to power up
  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 21,385 posts

:welcome:   Granthickey,

 

Sorry to hear about your build problems  :(

 

When you say you get nothing at all do you mean that when you press the case power on button you get no hard drive LED flickering, DVD drive tray will not open/close and no cooling fans spinning up etc.

 

NB: Just a heads up your OP was moved to this forum as the Waiting Room is not for tech or malware assistance but for posting in if you have waited for three days or more and not received a reply to your OP or last post.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP