Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Force a HDD to use UDMA and not PIO

hdd interrupts.exe heavy cpu usage really grinds my ears

Best Answer paws , 09 January 2017 - 03:16 AM

Hi, see if the following link helps:http://techlogon.com...ck-in-pio-mode/ If you do go into the Registry then before you do make sure you have a good back up of your complete Registry (Erunt... Go to the full post »


  • Please log in to reply

#1
Dr. Schnellinger (Again)

Dr. Schnellinger (Again)

    Member

  • Member
  • PipPip
  • 15 posts

Hi there.

 

Is it possible to force a HDD to usa UDMA mode and never PIO?

 

I'm having a tough CPU usage when I try to copy something to a 80GB SATA hard drive, on SATA port 1.

 

I already tried uninstalling the drive through device manager and I still have the problem, I also tried to uninstall the "Main IDE channel" (Or whatever it reads in english) and it's still fu'd up.

 

I had this problem months ago with another motherboard and the solution was to uninstall the "Main IDE channel" and the HDD at the same time and then reboot.

 

here's a pic of that "Main IDE channel"

 

3F2.jpg

 

On the properties of that I noticed the transfer mode is PIO and not UDMA at it should be.

 

I thought the problem could be the HDD itself but no, it's ok.

Then I thought it could be the SATA port, but I tested it with a Linux distro (Chakra 2012 Archimedes) and copied a heavy folder (Like 16GB) and the transfer rate was ok. Then there's something wrong with the drivers, I believe.

 

I'm using WindowsXP Professional 32-Bit Service Pack 3.

My mother board is a ASRock P4VM8 (Socket-478), here's a pic

P4VM800(L1).jpg

 

So, finally, how do I force the hard drive to use UDMA and never PIO?

 

 


  • 0

Advertisements


#2
paws

paws

    WTT Tech Teacher

  • Tech Academy Moderator
  • 629 posts
✓  Best Answer

Hi, see if the following link helps:

http://techlogon.com...ck-in-pio-mode/

 

If you do go into the Registry then before you do make sure you have a good back up of your complete Registry (Erunt is good) a System Restore point and a validated disc image & a boot disc able to access  your disc image  (Macrium reflect free is good)

 

Also it's not clear from the photo but your capacitors may be failing.... look at each one carefully, the tops should be flat, and the vents should not show any outward bulge..If they are in any way convex then they at failing and basically that's the end of the motherboard.... unless you are very handy with a soldering iron!

 

If the tops of the capacitors are flat then that is how they should be.

Regards

paws


  • 0

#3
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,384 posts

Hi,

 

If the drive works fine on linux then its probably related with drivers or some software conflict.

 

Make sure you have the correct driver for the Sata controller (SATA driver ver:3.00b) http://www.asrock.co...ad&os=2K#osXP32


  • 0

#4
Dr. Schnellinger (Again)

Dr. Schnellinger (Again)

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts

Hi, see if the following link helps:

http://techlogon.com...ck-in-pio-mode/

 

If you do go into the Registry then before you do make sure you have a good back up of your complete Registry (Erunt is good) a System Restore point and a validated disc image & a boot disc able to access  your disc image  (Macrium reflect free is good)

 

Also it's not clear from the photo but your capacitors may be failing.... look at each one carefully, the tops should be flat, and the vents should not show any outward bulge..If they are in any way convex then they at failing and basically that's the end of the motherboard.... unless you are very handy with a soldering iron!

 

If the tops of the capacitors are flat then that is how they should be.

Regards

paws

Now that you mention it, yes the three top capacitors have outward bulges (Those right over the CPU socket, also this pic is a reference), they might be failing, but then why does the drive works fine under linux?


  • 0

#5
paws

paws

    WTT Tech Teacher

  • Tech Academy Moderator
  • 629 posts

As SleepyDude mentions, it could well be a driver issue... or a software conflict

 

However,

 

if the caps are showing signs of convex tops then its not worth doing anything at all until you have either replaced the motherboard  and of course reinstalled the operating system, or carefully replaced the failed caps.

 

It's possible that your computer may "limp" along for some time with the failed caps, if so that will allow you time to plan the remedial work, or replace the whole machine and of course make sure that your back up strategy has worked perfectly and check that you have multiple copies of everything you need with at least one copy kept safe offsite on removable media.

Regards

paws


  • 0

#6
FreeBooter

FreeBooter

    Member 1K

  • Member
  • PipPipPipPip
  • 1,120 posts

Some drives have to operate in PIO (Programmed Input/Output) mode and others can operate in DMA mode. All of the settings are set to auto within BIOS setup utility. When a drive operates in PIO mode, all of the data passes through the processor. In DMA (Direct Memory Access), the processor is bypassed and the drives can communicate with the memory directly. This is much more efficient and it frees up the processor.


  • 0

#7
Dr. Schnellinger (Again)

Dr. Schnellinger (Again)

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts

You guys should have a statue in Russia or something.

 

Now the [bleep] thing works!

This is what I did, or "the log":

-First I followed the tutorial linked by paws, then copied a 600M rar file, the traditional way, and it was ok the first.. like 5 seconds so I cancelled the copy.

 

-Then I tried to copy a folder with 22.972 files and 4,20GB With TeraCopy (I use this one for big tasks), the problem showed up again.

 

-Then I uninstalled the HDD and installed the VIA RAID utility and reboot.

 

-Then tried to copy the same folder again and... success!

 

I have that program since 2015 but I never installed it since I thought it was for RAID systems and I never tried to plug in a SATA drive on those ports before

(I know nothing about RAID, it doesn't sound too interesting for me anyway :D).

 

Thanks for the help.

Moderators can mark this thread as solved.


  • 0






Similar Topics


Also tagged with one or more of these keywords: hdd, interrupts.exe, heavy cpu usage, really grinds my ears

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP