Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Apache home dns server


  • Please log in to reply

#1
Mikepmac

Mikepmac

    Member

  • Member
  • PipPip
  • 22 posts
I am kind of a noob I set up a home dns server pointed my domain hostileanon.com I have Wordpress up on my home lamp server all ports open on home router 80 8080 443 pointing to my external iPad 192.168.0.126 I tried to install a ssl cert with lettsencrypt and it said no server name was in the.conf I set the server name to www.hostileanon.com in sites-enabled/000-default.conf I created a virtual host with from what I understand to be proper bind settings everything works great at home on my LAN but I can't get a browser outside my house to pull up my website without timing out I need help I have been stuck for months
  • 0

Advertisements


#2
RKinner

RKinner

    Malware Expert

  • Expert
  • 19,783 posts
  • MVP

C:\Windows\system32>nslookup www.hostileanon.com
Server:  75-114-81-1.net.bhntampa.com
Address:  75.114.81.1
 
Non-authoritative answer:
Name:    www.hostileanon.com
Address:  192.168.0.126

 

 

So your DNS info is getting out there.  The problem is that you can't use the 192.168. address range on the Internet.
 
If you ask Whois
 
it will tell you that 192.168.0.126 is a Private or Reserved IP Address
 
You need to be using an IP address assigned by your ISP.  Your router normally has one address assigned to it by the ISP.  All of the PCs and other devices on the LAN served by the router whether wireless or wired are using an address assigned by the router in a Private Ip range such as 192.168.0.x or 172.16.x.y or 10.x.y.z.  Traffic from a PC or other local device has its return IP address changed before it leaves the router to the assigned address and at the same time the assigned port may also be changed.  The router keeps track of what changes it has made and when it gets incoming packets from the Internet it looks at the port number and uses that to know what local Ip address to send the packet to.  This is called Network Address Translation.  
 
If you don't turn off or reset the router it will usually keep the same ISP assigned address so you could advertise the router's ISP assigned address.  To find it if you don't know it:
 
 
The router would need to know which local PC is supposed to handle incoming HTTP traffic (port 80) and any other special services you may want to offer.

  • 0

#3
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
I set my router to port forward 80 I'm not sure what solution you are proposing my server is set static to the ip mentioned what settings should I change? Home router? Apace server ip? I have webmin and it is running on standard port I'm sorry if I missed your answer obviously I am not understanding
  • 0

#4
RKinner

RKinner

    Malware Expert

  • Expert
  • 19,783 posts
  • MVP

Use one of the PCs on your home network and go to:

 

https://whatismyipaddress.com/

 

What IP address does it say you have?  Tha's the one your DNS needs to advertise to the outside world.


  • 0

#5
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
It is showing an IPv6 what am I pointing and where
  • 0

#6
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
Go to domain provider and add IPv6 it is already pointing IPv4 to my home server at address mentioned earlier
  • 0

#7
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
?
  • 0

#8
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
Should I use the listen directive and enter IPv6 in brackets:80 I'll try that
  • 0

#9
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
Tried to make an ssl after error no listening socket and I deleted the ssl section in my ports.conf just for fun I guess lol after I added my IPv6 that I got off whatismyip.com it still says I need to set my server name but like I said earlier I changed it in 000-default.conf
  • 0

#10
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
I feel like Donnie from the big lebowski like a child who wanders into a movie theater with no frame of reference I'm at the point where I'm just tearing up.conf files
  • 0

Advertisements


#11
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
I figured out my home router has a different address than what the website says meaning I thin my isp is blocking public ip's soooooooooooo???????????
  • 0

#12
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
Do I set my web server external address to my router ip?
  • 0

#13
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
Change the registrar a records? Change vhost address? Say beetlejuice 3 times? Feed the maguai after midnight? what have I done
  • 0

#14
RKinner

RKinner

    Malware Expert

  • Expert
  • 19,783 posts
  • MVP

Eastern Standard time here in Florida.  Have to sleep sometimes.

 

All ISPs will block traffic to 192.168.x.y as it is not a valid IP address on the Internet.

 

There should be an IPv4 address for your router as only portions of the Internet are really using IPv6 so everyone is getting both for now.

 

See if you can get an IP4 address from:

 

http://whatismyipaddress.com/ds-check

 

You have to use the IPv4 address assigned by your ISP in your DNS record where you now have 192.168.0.126.  It will usually be the IP address on the WAN side of your router so you can log in to it and see if it has an IPv4 address assigned.

 

Once you do that then see if the record is propagating through the network by doing

nslookup  www.hostileanon.com

from an elevated command prompt on a Windows PC outside of your home. 

Win 7: Start, All Programs, Accessories then right click on Command Prompt and Run as Administrator. 

Win XP: Start, All Programs, Accessories then Command Prompt 
 
 
 You can then test your connectivity with
ping  www.hostileanon.com

or

tracert -d  www.hostileanon.com

If you replace the www.hostileanon.com with your IPv4 address in the above commands then both should work now and show you what to expect.


  • 0

#15
Mikepmac

Mikepmac

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
Change my registrar a record to my router IPv4? Or add my router IPV4 to my apache home server somewhere?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP