Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Display will not work on new build


  • Please log in to reply

#1
boxofbluecrayons

boxofbluecrayons

    New Member

  • Member
  • Pip
  • 1 posts

I just built a new computer and i triple check all of my connections. I have a GIGABYTE LGA1151 Intel H110 Micro ATX DDR4 Motherboardwhich i just switched out. Trying to display with my flat screen.  PSU is 520w, 2 memory slot 2x4gb, Intel Corei3-7100 7th Gen Core Processor. Not sure if i need a VGA card or not any help is greatly appreciated.


  • 0

Advertisements


#2
Yisroel

Yisroel

    GeekU Junior

  • GeekU Junior
  • 841 posts

The PC runs all fine just doesn't show anything on the display?

 

On which interface is it plugged in the PC and on which on the monitor (VGA, HDMI, DP, DVI?)

 

Which monitor do you have?


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP