Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

search function in Excel no longer looks in CSV files

Excel

  • Please log in to reply

#1
IndyBlue

IndyBlue

    Member

  • Member
  • PipPip
  • 55 posts

At my job, I have to work with many CSV files. I don't know what happened, but I used to be able to do searches for text in any folder on my computer, and it would pull every file type. For example, if I wanted to find all CSV payment files in January in which we made a payment to "Smith", I would just type "Smith" in the search bar, indicate to search in contents, and I would get every file in that folder that had a "Smith" in it. It was great.

 

Now, I only get the Excel files. I have tried researching this online but to no avail. I believe this change happened when our IT guy upgraded me to Office 2016. 

 

Can anyone help? I would prefer to stay away from apps (but am not ruling them out if they would help); I would simply like to search as I did before: I need to be able to search within the contents of CSV files.

 

Thanks in advance for your help!

 

Indy


  • 0

Advertisements


#2
Yisroel

Yisroel

    GeekU Junior

  • GeekU Junior
  • 841 posts

Hi IndyBlue,

 

Searching within CSV files shouldn't be affected by which version of Microsoft Office you have installed. In fact, it will work even if you don't have Microsoft Office installed at all.

 

What I'd suggest for you is first to make sure that in the Indexing Settings it is set to search the contents of CSV files. For that, you should search in the Start Menu for Indexing Options and open the Indexing Options from the results. In that windows click Advanced and go to the File Types tab. Scroll down to the CSV file type and make sure the radio button is at the Index Properties and File Contents option. like this:

dllhost_2017-07-09_13-21-35.png

 

If that is set correctly you can try to Rebuild the Index. You'll find the Rebuild in the  Index Settings tab of that same Advanced dialog box:

qpgGN61.png


  • 0






Similar Topics


Also tagged with one or more of these keywords: Excel

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP