Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Settings ISP modem/router firewall And RDP connection issues


  • Please log in to reply

#1
HaraMo

HaraMo

    Member

  • Member
  • PipPipPip
  • 341 posts

Dear

As ISP has no detailed user guide for their own modem/router , I hope someone here could help.

I can upload photos of the firewall settings maybe someone knows what to do.

The firewall has two options : low, medium and high.

RDP connection fails completely if set on high.

Low, connection is estsblished but it seems not 100% stable : a few seconds screen freezes , message that there is no connection then suddenly the connection is back working. Also slow connection .

I have two ISPs , the moment I switch to the other one ( only modem device , a router connnected to it ), no connection loss or slow connection.

I use a router even with the modem/router device .

I just want to change firewall settings to high and setup the exception for the RDP connection and hope also to solve the connection loss issue.

 

Update: I added a pdf file that containts the photo's of the settings of the firewall and portmapping of the ISP modem/router device. Maybe someone knows which company produces this modem router by looking to the photo's? Maybe I can find this way a userguide?

Attached Files


Edited by HaraMo, 30 June 2018 - 05:08 AM.

  • 0

Advertisements


#2
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,363 posts
  • MVP

Do you have a make & part number for the modem or router you are trying to configure?  Should be on the back or bottom.  Also what version of Windows is your PC?

 

From what your pdf says the Low firewall  setting is no firewall so if RDP's not working reliably then it's not a firewall issue.   I would check the speed of the connection with http://www.speedtest.net/ Compare it to the good connection.

 

To get it to work on High you will need to tell the firewall to pass TCP port 3389.

 

Have you ever tried TeamViewer instead of RDP?  https://www.teamviewer.us/downloads/(free for personal use).


  • 0

#3
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

 

 

Do you have a make & part number for the modem or router you are trying to configure?  Should be on the back or bottom.   P/N: 253670393 , Sagemcom,  b - box 3V + 
Also what version of Windows is your PC? Windows 8.1 64 bit version 6.3
I would check the speed of the connection with http://www.speedtest.net/ Compare it to the good connection.  TEST results: ping 5 ms, download: 95.36 Mbsp, upload 25.54 Mbps (fiber to the home) should be ok.
To get it to work on High you will need to tell the firewall to pass TCP port 3389.  Will give it a try but need first to know how to setup ports on this ISP modem.
Have you ever tried TeamViewer instead of RDP?  https://www.teamviewer.us/downloads/(free for personal use).  Yes, and Teamviewer works without any issues.

Edited by HaraMo, 02 July 2018 - 07:44 AM.

  • 0

#4
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,363 posts
  • MVP

See if this helps:

 

https://www.proximus...your-modem.html

 

You want to use: TCP port 3389

 

Also make sure you have the network set to Private and not Public in Windows.

 

There is a program called tcpview.  https://live.sysinte...com/Tcpview.exe

 

Download, Save and then run it by right clicking and Run As Admin.

Then File, Save As (to your desktop), tcp , OK.  This should createa  file tcp.txt on your desktop.  Attach or copy and paste it to a reply.  Repeat for the second network.

 

Also 

 

Get Process Explorer

http://live.sysinter...com/procexp.exe
Save it to your desktop then run it (Vista or Win7+ - right click and Run As Administrator).  

View, Select Column, check Verified Signer, OK
Options, Verify Image Signatures


Click twice on the CPU column header  to sort things by CPU usage with the big hitters at the top.  

Wait a full minute then:

File, Save As, Save.  Note the file name.   Open the file  on your desktop and copy and paste the text to a reply.


Make a second log when connected to the second network.
 


  • 0

#5
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

 

See if this helps:

 

https://www.proximus...your-modem.html

 

You want to use: TCP port 3389

 

Also make sure you have the network set to Private and not Public in Windows.

I tried to addd the port using the steps described in the link you send me, but the steps are not clear.
 
see pdf of the picture what I did, not sure if the 3389 port should be filled in in every column or only some? 
as internal host I used the device connected to the bbox, which is the tp link router. 
 
normally tp link router has no issues to let RDP work, so I don't need to port forward on the tp link to my laptop?
 
Network in Windows is  already , in Dutch language,  'particulier netwerk' I assume this is the same as private network.
 
Next steps will do it soon. I first want to know if the portmapping of port 3389 is setup correct?

 

Attached Files


  • 0

#6
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,363 posts
  • MVP

In the External  Port End box I would put 3389 too.  You are telling it a range of ports so even tho it's a single port you still need to define both ends of the range.  Not sure what they want under Service.   It looks like they might have some menu options - in the instructions it looks like there is a down arrow  in the Service box to open a menu.

 

Assuming the 192.168.x.x address is the external address on the TP Link that should work. 


  • 0

#7
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

In the External  Port End box I would put 3389 too.  You are telling it a range of ports so even tho it's a single port you still need to define both ends of the range.  Not sure what they want under Service.   It looks like they might have some menu options - in the instructions it looks like there is a down arrow  in the Service box to open a menu.

 

Assuming the 192.168.x.x address is the external address on the TP Link that should work. 

 

ok I added the port in external end box. now 3389 is in external port start, external post end and also in internal port.

 

The service is not anymore then predefined settings: i can choose from: ftp, ftp-data, SSH, TELNET,  DNS, http, https and more ..; .


  • 0

#8
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,363 posts
  • MVP

Sounds like it is OK to leave Service blank.  So does it work now?


  • 0

#9
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

Sounds like it is OK to leave Service blank.  So does it work now?

 

I tested it immediatelly after settin up the port , then  changed firewall on high, but no connection possible. then put firewall on middle, connection works.

 

Today again tried to connect to RDP with firewall high, but no connection possible.


  • 0

#10
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

I went to firewall settings and added the same port as I added to port mapping then the RDP connection works with firewall set on high.

 

See pdf attached, I just want to know if the values are ok, I only want that the computers home can have access to RDP. I tried to put the internal ip adres of the tp link router where 0.0.0.0/0 is now the value, but I receive an error that it should be a subnetmask.. .

 

 

If I would delete the port forwarding, would RDP work with only the firewall setting? will give it a try.  The satus of the portforwarding 3389 is 'disabled' and connection still work to RDP.

 

So I only need to add this port to the firewall configuration. Thanks a lot.

 

Do you still need the logs you asked?

 

I just hope I can change the settings of the 3389 firewall setting, tosomething more secure?

Attached Files


Edited by HaraMo, 04 July 2018 - 05:18 AM.

  • 0

Advertisements


#11
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,363 posts
  • MVP

All traffic will be sourced with the TPLink's address so use its address of 192.168.x.y or to make sure it will work if it gets a new address 192.168.0.0/16 or 192.168.x.0/24


  • 0

#12
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts
I dont follow... .

Is it about the firewall setting ? I dont see their the tplink is adress ?
  • 0

#13
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,363 posts
  • MVP

firewall setting

the sagecom is going to use DHCP to assign IP addresses to whatever connects to it.  I'm assuming it uses the range 192.168.x.0/24 but I don't know what x is so 192.168.0.0/16 should work regardless.


  • 0

#14
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

I have another issue, teamviewer does not work anymore.. also a port to set in firewall?


  • 0

#15
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,363 posts
  • MVP

https://community.te...c-hId-821590845


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP