Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Settings ISP modem/router firewall And RDP connection issues


  • Please log in to reply

#16
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

firewall setting

the sagecom is going to use DHCP to assign IP addresses to whatever connects to it.  I'm assuming it uses the range 192.168.x.0/24 but I don't know what x is so 192.168.0.0/16 should work regardless.

I checked the other settings, yes there is DHCP showing the sagecom  internal ipadres. Default internal ip adres of sagecom is 192.168.1.1.

 

 

In firewall settings (column source ip address)  I see  192.168.1.0 /24.

 

So If i change this source ip adres to the ip adres of my tp link external ipadres: 192.168.x.y without the /24 , will this limit the port only be accessible by tp link  shared DHCP ip adresses?

So no other device will be able connecting to the sagecom modem/router as the ports will be not accessible by other ip adresses that thesegecom  shares using DHCP?

Maybe aslo a good idea to limit the numbers of ipadress the sagecom can have ( pool start and pool end)?


Edited by HaraMo, 04 July 2018 - 05:14 PM.

  • 0

Advertisements


#17
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,474 posts
  • MVP

If the TP Link is a true router then it's going to offer its own set of IP addresses to everything connected to it and if it's the only thing attached to your Sagecom then it's only going to need the one address but I don't see the point of trying to limit the DHCP range.  Nobody else is going to be using the Sagecom's addresses.  If the TP Link is just an extender without its own DHCP and just passes data back and forth then the Sagecom's addresses will be shared among the devices connected to the TP Link.  The 192.168.1.1 is the address of the Sagecom on the inside and is where the TP Link will be sending all of the packets that are not local.The TP Link will have a different address assigned by the Sagecom's DHCP but it will be within the 192.168.1.0/24 subnet. 

 

If you open an elevated command prompt on a windows PC

 

Win 7: Start, All Programs, Accessories then right click on Command Prompt and Run as Administrator
Win 8: http://www.eightforu...indows-8-a.html
win 10: http://www.howtogeek...-in-windows-10/
 

 

and type:

 

tracert  -d  8.8.8.8

 

What are the first three addresses it sees?


  • 0

#18
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

If the TP Link is a true router then it's going to offer its own set of IP addresses to everything connected to it and if it's the only thing attached to your Sagecom then it's only going to need the one address but I don't see the point of trying to limit the DHCP range.  Nobody else is going to be using the Sagecom's addresses.  If the TP Link is just an extender without its own DHCP and just passes data back and forth then the Sagecom's addresses will be shared among the devices connected to the TP Link.  The 192.168.1.1 is the address of the Sagecom on the inside and is where the TP Link will be sending all of the packets that are not local.The TP Link will have a different address assigned by the Sagecom's DHCP but it will be within the 192.168.1.0/24 subnet. 

 

If you open an elevated command prompt on a windows PC

 

Win 7: Start, All Programs, Accessories then right click on Command Prompt and Run as Administrator
Win 8: http://www.eightforu...indows-8-a.html
win 10: http://www.howtogeek...-in-windows-10/
 

 

and type:

 

tracert  -d  8.8.8.8

 

What are the first three addresses it sees?

the tp link is a router as explained before, so yes it has dhcp.

the external ip adres of tp link is an ip adres received from sagecom as you said from default range 192.168.1.0/24 subnet.

the internal ipadres of tp liink is not complete the same only the two first digits are the same: 192.18.d.z 

I rather not give complete Ip adresses to avoid to publish them on internet with more security risque..

 

the sagecom has ipv4 pool start and end  and ipv4 TV pool start en end.  So the tp link router is connected to it, and the TV decoder and the smart TV. they  have all an ip adres in default range 192.168.1.x 

all other devices (laptops, phones ) are connected to the tp link.

 

An extra switch is connected to the sagecom.


  • 0

#19
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,474 posts
  • MVP

192.168.0.0/16 addresses are Private and cannot be used on the Internet so there is no need to be concerned about security.

 

What is the extra switch connected to the Sagecom for?


  • 0

#20
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

Bef

 

192.168.0.0/16 addresses are Private and cannot be used on the Internet so there is no need to be concerned about security.

 

What is the extra switch connected to the Sagecom for?

 

Before I had one ISP, the device was a only modem.

So one port . so I used the switch to have more ports.

 

Now It's there just in case  the ISP of sagecom has issues, then I can connect to the  modem back of the other ISP.

 

Then the smart TV connection can also be connected to the switch, with the connection to the tp link router.

 

 

 


  • 0

#21
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,474 posts
  • MVP

OK.  What's the status now?  Any of the port forwarding working?


  • 0

#22
HaraMo

HaraMo

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 341 posts

OK.  What's the status now?  Any of the port forwarding working?

I only used the firewall settings, no port forwarding needed. and it seems the RDP connecton is now stable.

But I also did something else after searching in google, and notices that RDP was after this step stable.

But now firewall on sagecom is not anymore on low,(off you said) but on high, so I 'm happy firewall on sagecom is on with the RDP and teamviewer port added in firewall settings, all works.

 

What I did about the step:

I enabled keep-alive interval and has value 1 , this to be found in  keep -alive connection interval  using Terminal Services with command gpedit.msc (after making windows 8 recognize this command, also googled it).

 

 

Configure keep-alive connection interval     Enabled

Keep-Alive interval:  1

After making the above change and restarting please test to see if you are able to maintain a connection.

 

If you would advise me to disable it, mayby this terminal service had nothing to do with RDP?


  • 0

#23
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,474 posts
  • MVP

Terminal Services was required for RDP back in XP & Vista:
 

 

Default Description

Allows users to connect interactively to a remote computer. Remote Desktop and Terminal Server depend on this service. To prevent remote use of this computer, clear the checkboxes on the Remote tab of the System properties control panel item.

 

 

http://www.blackvipe...minal-services/

 

so I would leave it on.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP