Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Icons not responding on boot-up.

- - - - -

  • Please log in to reply

#16
Ste

Ste

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 238 posts

Hi, I have checked the disk as you said. I am not sure if it has made any difference as yet; on first boot it was slow on second it was fast.

 

On trying to do a new instal on a formatted SSD with no other drives connected, I get the message: ‘Can’t be installed the selected disk is of the GPT partition style’.

I know little about the differences between MBR and GPT only that GPT is preferable.

 

It did surprise me though, as the drive in question had been a clone of the OS from March this year and I have not knowingly changed partition type. In other words the current working, though problematic drive, has descended from the one I am trying to instal on to. Is this due to the formatting of the drive before the installation attempt?

 

The pen drive installation I am using is a recent one, the original, which has been overwritten was a few years old.

 

Board info:

 

Baseboard ASUSTeck Computers inc

Baseboard Product Sabertooth 990FXR2.0

Baseboard Version Rev 1.xx


  • 0

Advertisements


#17
peterm

peterm

    Trusted Tech

  • Technician
  • 3,345 posts

That is your bios setup causing the install error 

GPT allows more partitions. From here https://www.diskpart...d-gpt-1203.html

If your hard drive is less than 2TB and you don’t need more than 4 primary partitions, you can choose MBR.

▶If your hard drive is over 2TB and you want to create over 4 primary partitions, please switch to GPT. Besides, if your motherboard supports UEFI boot and the operating system is 64-bit, it is advised to choose GPT, otherwise, go for MBR instead.

Your bios will be in legacy mode hence the issue.You have to decide what to do either change disk back to MBR 

Or Change bios to uefi if you do that current disk MIGHT have boot issues


  • 0

#18
Ste

Ste

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 238 posts

Hi, I managed to install Windows on an SSD drive after changing it to MBR. It booted several times OK. Then I attached the original working drive. This booted as usual but with no option to change which drive should be used to boot. I tried to change this in the BIOS but again but received the message to change to a bootable drive.

 

In other words, since the other drive had been connected, the new OS drive was no longer recognised but is listed in the BIOS.

 

In the ‘This PC’ window I see this second OS drive as ‘E’, if I click on it, it show as empty?


  • 0

#19
peterm

peterm

    Trusted Tech

  • Technician
  • 3,345 posts

You either have to run MBR which is what you have on the ssd and working.

Or Run Bios in Uefi Mode and convert to GPT.  From Tom's https://forums.tomsh...rboard.2017525/

Windows is weird. If you're booting in Legacy mode, your boot drive must be MBR. If you're booting in UEFI mode, your boot drive must be GPT. No other OS that I know of does this.

All UEFI boards also support legacy booting.

You can have any mismatch of MBR/GPT drives you like in a system, so long as the boot drive matches the above conditions.


  • 0

#20
Ste

Ste

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 238 posts

I’m not sure where that leaves me. After checking the BIOS I see it said OS type UEFI. Other settings are:

 

Under Boot Device Controls: UEFI & Legacy OpRomM;

Boot from Network: Ignore

Boot from storage: Both UEFI 1st

Boot from PCIe PCI Expansion drive UEFI 1st

 

 I have tried changing these settings but the boot up is just the same.

I tried again with the Pen drive OS rescue options and typed in ‘Rebuild Bcd’. It found ‘Installation 1’

[1] D:Windows and asked if I wanted to add it to the Boot list, so I entered 'Y' and it responded with: ‘the requested system device cannot be found’ I don’t know if that is relevant but I found it puzzling. Not sure where to go from here; am I misunderstanding something you are saying?


  • 0

#21
peterm

peterm

    Trusted Tech

  • Technician
  • 3,345 posts

You have to decide if you want to boot MBR which has the following limitations 

less than 2TB and you don’t need more than 4 primary partitions

is your C: drive

1) less than 2TB

2) do you need more than 4 Primary Partitions 

If Yes to both then MBR is fine.

 

If you want to Boot UEFI

If your hard drive is over 2TB and you want to create over 4 primary partitions, please switch to GPT

is your C: drive

3) 2TB or bigger 

4) Do you need more more than 4 Primary Partitions

If Yes to both or Yes to question 4 you have to format C: to GPT and set bios to UEFI.

 

Does this help explain it better https://forums.tomsh...orth-it.3648859

If in doubt please ask. I can always ask another Tech for advise/help

 

[1] D:Windows and asked if I wanted to add it to the Boot list, so I entered 'Y' and it responded with: ‘the requested system device cannot be found’ I don’t know if that is relevant but I found it puzzling

 

 

My guess on this is the drive D: is the GPT drive with a boot sector on it that is why.

 

I know little about the differences between MBR and GPT only that GPT is preferable

 

I have legacy Mode - no choice all my disk are MBR and no issue.

I run XP, Windows 7, Windows 10 on separate drives all mbr and Windows 11 in Virtual on mbr - No uefi involved


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP