Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

HOW TO TURN OFF "SWITCH TO MICROSOFT EDGE"


  • Please log in to reply

#1
JoMalig

JoMalig

    Member

  • Member
  • PipPip
  • 27 posts

Hello,

 

How to turn off the below pup-up from showing every once in a while when using Internet Explorer 11? (Windows 10 OS)

I'm not a fan of internet explorer but at work, we rely on one particular website who unfortunately do not support all other web browsers except Internet Explorer 11.

It also do not support all other OS except Windows.

 

ScreenShot.jpeg

 

Thanks


  • 0

Advertisements


#2
RKinner

RKinner

    Malware Expert

  • Expert
  • 24,122 posts
  • MVP

See if the registry hack in More Information on the following website works for your popup:

 

https://support.micr...08-a585f4fa08d4


  • 0

#3
JoMalig

JoMalig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts

Thanks, I will try this one and let you know if it worked or not.


  • 0

#4
JoMalig

JoMalig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts

Hi, 

 

Sad to say but it didn't work. Just now it showed up again.

 

Thanks anyway. I'll just be careful not to click the first choice.

Otherwise, I may not be able to open IE again.


  • 0

#5
RKinner

RKinner

    Malware Expert

  • Expert
  • 24,122 posts
  • MVP

OK.  Trying to get my laptop which still has IE on it to bring up the same warning but no luck so far.  I do notice there is an Add-on called IEtoEdge BHO which sounds suspicious.  Have you disabled it?

 

My laptop hasn't been powered up for a while and is missing some updates so the notification may be added in one of the missing updates.  Will try it again once it is up-to-date.


  • 0

#6
RKinner

RKinner

    Malware Expert

  • Expert
  • 24,122 posts
  • MVP

OK I'm getting slightly different warnings after updating but I think they are coming from Tasks:

 

Search for

task scheduler

and hit Enter

That should bring up the Task Scheduler.

Click on Task Scheduler Library and look in the pane to the right.  Scroll down and see if you find 

MicrosoftEdgeUpdateTaskMachineCore

 

Right click and Disable or Delete.  Repeat for any similar tasks.  Does that help?


  • 0

#7
Gary R

Gary R

    Trusted Helper

  • Malware Removal
  • 437 posts

Have you unchecked ... Get tips, and suggestions when I use Windows ... in Settings > System > Notifications

 

You might also want to uncheck ... Offer suggestions on how I can set up my device

 

A lot of the nags from Microsoft come via these routes.


  • 0

#8
DR M

DR M

    The Grecian Geek

  • Malware Removal
  • 3,308 posts

Have you unchecked ... Get tips, and suggestions when I use Windows ... in Settings > System > Notifications

 

 

That worked for me. :)


  • 0

#9
JoMalig

JoMalig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts

Hello,

 

 

OK.  Trying to get my laptop which still has IE on it to bring up the same warning but no luck so far.  I do notice there is an Add-on called IEtoEdge BHO which sounds suspicious.  Have you disabled it?

 

My laptop hasn't been powered up for a while and is missing some updates so the notification may be added in one of the missing updates.  Will try it again once it is up-to-date.

 

The status is Enabled. How can I Disabled it?

 

IEToEdge BHO.jpg

 

 

OK I'm getting slightly different warnings after updating but I think they are coming from Tasks:

 

Search for

task scheduler

and hit Enter

That should bring up the Task Scheduler.

Click on Task Scheduler Library and look in the pane to the right.  Scroll down and see if you find 

MicrosoftEdgeUpdateTaskMachineCore

 

Right click and Disable or Delete.  Repeat for any similar tasks.  Does that help?

 

By default, its already disabled but i'm still getting this pup up.

 

MSEdgeUpdateTaskMachineCore.jpeg

 

Have you unchecked ... Get tips, and suggestions when I use Windows ... in Settings > System > Notifications

 

You might also want to uncheck ... Offer suggestions on how I can set up my device

 

A lot of the nags from Microsoft come via these routes.

 

I will try this one and lets see what happen. I will let you know.

 

 

 

Thanks for the replies.


  • 0

#10
JoMalig

JoMalig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts

Have you unchecked ... Get tips, and suggestions when I use Windows ... in Settings > System > Notifications

 

You might also want to uncheck ... Offer suggestions on how I can set up my device

 

A lot of the nags from Microsoft come via these routes.

 

Its already unchecked by default.  :upset:


  • 0

#11
Gary R

Gary R

    Trusted Helper

  • Malware Removal
  • 437 posts

 

The status is Enabled. How can I Disabled it?

 

You may find this article helpful .... https://www.zabkat.c...ve-edge-bho.htm


  • 0

#12
JoMalig

JoMalig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts

 

 

The status is Enabled. How can I Disabled it?

 

You may find this article helpful .... https://www.zabkat.c...ve-edge-bho.htm

 

 

Just now I tried this one, lets see what happen.  :D


  • 0

#13
JoMalig

JoMalig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts

 

 

The status is Enabled. How can I Disabled it?

 

You may find this article helpful .... https://www.zabkat.c...ve-edge-bho.htm

 

 

I was able to disabled it and for a few days the pop up did not show.

But today, it came back. And when I checked the add-ons, it also came back to Enabled.

 

Well is guess im stuck to this.

 

Thanks for all the help.


  • 0

#14
RKinner

RKinner

    Malware Expert

  • Expert
  • 24,122 posts
  • MVP

If you start IE by right clicking and Run as Administrator the Disable button works.

 

I looked at the BHO in one of our anti-virus tools (FRST64.exe) and it says:

 

BHO: IEToEdge BHO -> {1FD49718-1D00-4B19-AF5F-070AF6D5D54C} -> C:\Program Files (x86)\Microsoft\Edge\Application\97.0.1072.62\BHO\ie_to_edge_bho_64.dll [2022-01-13] (Microsoft Corporation -> Microsoft Corporation)
BHO-x32: IEToEdge BHO -> {1FD49718-1D00-4B19-AF5F-070AF6D5D54C} -> C:\Program Files (x86)\Microsoft\Edge\Application\97.0.1072.62\BHO\ie_to_edge_bho.dll [2022-01-13] (Microsoft Corporation -> Microsoft Corporation)
 
97.0.1072.62 is the current version of Edge so that means that every time Edge gets an update the BHO will be reinstalled into a different folder so we can't just change permissions on the existing .dll and expect to to hold.
 
There are two tasks in Task Scheduler Library which seem to be the update method but you may not want to turn them off if you use Edge for other purposes.
 
Uninstalling Edge doesn't seem to be a simple thing either. 
 
Probably the easiest way would be to use REVO Uninstaller:
"Revo Uninstaller: First, start by closing all Microsoft Edge browser windows, then run the Revo uninstaller. From the list on your PC, choose Microsoft Edge, then select uninstall on the top panel. Next, confirm ‘restore point creation’ to initiate the procedure. You can also search for residual files and other traces as the final step."
https://www.revouninstaller.com/revo-uninstaller-free-download/ You want the freeware version either installed or portable.
 
I looked at the registry for where the {1FD49718-1D00-4B19-AF5F-070AF6D5D54C} is used and I get:
 
HKEY_CLASSES_ROOT\CLSID\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_CLASSES_ROOT\ie_to_edge_bho.IEToEdgeBHO
HKEY_CLASSES_ROOT\ie_to_edge_bho.IEToEdgeBHO.1
HKEY_CLASSES_ROOT\WOW6432Node\CLSID\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Approved Extensions
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext\Stats\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ie_to_edge_bho.IEToEdgeBHO
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ie_to_edge_bho.IEToEdgeBHO.1
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\WOW6432Node\CLSID\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext\PreApproved\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Classes\CLSID\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Ext\PreApproved\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
HKEY_USERS\S-1-5-21-843280653-572172798-757907776-1001\SOFTWARE\Microsoft\Internet Explorer\Approved Extensions
HKEY_USERS\S-1-5-21-843280653-572172798-757907776-1001\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext\Stats\{1FD49718-1D00-4B19-AF5F-070AF6D5D54C}
 

I tried changing owner from System to Administrator on a few of them and there was no problem doing that.  Then I went in and removed Full Control and Read from everybody but Administrator and it allowed that too so if you are willing to go to the effort that might be a possibility. (Some of the references to the extension are subkeys and I just gave you the main key.  You would want to mess with the actual key that talks about the extension.) Might be enough to just work on the ones that mention:

ie_to_edge_bho.IEToEdgeBHO as these point to the actual dll.

 

A simple option if you don't have any other BHOs that you need in IE is to run IE with all extensions disabled:

 

Right click on the shortcut you use for IE select Properties and add  (space) -extoff at the end of the Target then a space and the URL of the home page you want to use.  OK

 

You will see a little note to the effect that you are running without add-ons but you can ignore it and it will go away when you go to a new page or you can x it out.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP