Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

XP/98 Networking Probs


  • Please log in to reply

#1
Hardluck Hank

Hardluck Hank

    Member

  • Member
  • PipPip
  • 34 posts
Currently I have a Win XP and a Win 98 computer connected via a Linksys Router. Both can see each other. The problem is that the XP computer looks only for a SharedDocs folder in the 98 computer. I am unable to create a SharedDocs folder at the top level of the 98 computer.

However, I would rather that the XP be able to see an entire drive on the 98 computer. I already have the drive on the 98 computer configured to be shared, but apparently the only thing the XP computer looks for is a SharedDocs folder. Is there some way to get the XP (or the 98 computer as well) to see entire drives on the other computer instead of just the SharedDocs folders?
  • 0

Advertisements


#2
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
First off, make sure the following is installed on BOTH MACHINES! Will be located on the network adapter properties:

Client for Microsoft Networks
File and Print sharing
TCP/IP Adapter
TCP/IP Protocol

Greazy Mcgeezy
  • 0

#3
Hardluck Hank

Hardluck Hank

    Member

  • Topic Starter
  • Member
  • PipPip
  • 34 posts
Not sure exactly how to get to the Network adapter properties, but assuming that you get there by control panel / network connections, select network bridge properties ... the following (all) selections are enabled on the XP:

Client for Microsoft Networks
File and Printer Sharing for Microsoft Networks
QoS Packet Scheduler
Internet Protocol (TCP/IP)

There wasn't any selection for TCP/IP Adapter.


For the Win 98 Computer, going to control panel / networking/ and then selecting properties for the TCP/IP -> (network card), the following are enabled:

Client for Microsoft Networks
File and Printer Sharing for Microsoft Networks

I'm not sure if this is where I should be looking or not. If some of the options are missing, where do I get them ?
  • 0

#4
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
That is exactly where you should be looking. On the 98 machine, you need to install the TCP/IP Protocol and I believe in 98 you will also have to installe the adapter. At the same window that you observed those options, you should see a button directly below them that states, "Add", there you will click "Protocol", and add the "TCP/IP Protocol". You should now be able to obtain IP automatically or give it a static address. Then you will want to go to the WINS option and make sure that "Enable NetBIOS over TCP/IP" is checked. See what happens after you do all this. It looks like the Windows XP machine should be fine with what is installed. And you may not have to install the TCP/IP adapter on the Win 98 machine.

Greazy Mcgeezy
  • 0

#5
Hardluck Hank

Hardluck Hank

    Member

  • Topic Starter
  • Member
  • PipPip
  • 34 posts
I was able to obtain the TCP/IP address automatically even before. I don't know what you mean by "Then you will want to go to the WINS option and make sure that "Enable NetBIOS over TCP/IP" is checked. See what happens after you do all this."

In 98, I can go to the TCP/IP->(my card), right click on properties, and there is a tab called "WINS Configuration", but there is no such option for "Enable NetBIOS over TCP/IP" for that tab or any other properties tab. Could you please be more specific in your instructions.

On the 98 machine, I can click on Network Neighborhood and see my own machine and "Entire network". I can also see those drives on my own machine that I can enabled to be shared. I cannot see any of the XP files.

However, I can execute "Run" and type in "\\XP-Computer" (the name of the XP machine, and see all those files on the XP machine that I have designated to be shared. So evidently something must be working. I have set up a new Network name other than MSHOME.

I have not found a way on the XP machine to view any file on the 98 machine. Using "run" and typing in the name of the 98 computer does not work like it does on the 98 machine.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP