Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

i have networking issues..........


  • Please log in to reply

#1
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Member
  • PipPip
  • 44 posts
Ok, so i have two computers i wanna hook together and share a dsl line and also share files..

so i got this cheap hub and some cables and when i went to set everything up there was issues....



i put it so that the two computers were plugged into the router and then the dsl line was in the uplink port and ran the setup wizard on both computers and i started sharing internet .. but as soon as i thought it was all working.. it wouldnt let me get into the shared folder on the other computer... so i thought i would check the internet to see if it worked.. and all of a sudden this little triangular yellow exclamation point popped up in the tray and it said... there is an ip address conflict or something.. and then the internet wouldnt work on either computer so i just unhooked the cables and hooked the dsl to one computer and clicked repair and it worked... so then later i went back to it and i tried to hook a crossover cable and bypass the hub and have the one computer have the internet hooked to it.. and share it through that computer.. so i got all that and now i can share files but it doesnt detect any internet... so now what do i do?????
why is this not working and is it possible for me to use the hub so that i can hook more computers to it in the future... all i wanna do is share internet and files and it has turned into a big ordeal because of some ip address sharing conflict or something........

PLEASE HELP!!!!

- Josiah
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
return to the original set up and make sure that your pcs are set to automatically detect their ips.

so basically you would have:

cable from wall to router's "in" port
then cables from router to pcs
make sure that the settings in the router are configured for dhcp on those ports.
  • 0

#3
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
i think it is all already setup like that...
  • 0

#4
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
well from your description of the original problem you had at least 2 machines with the same ip...that is not allowable. it seems like that was the only problem to begin with
  • 0

#5
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
ok then! sounds good. how do i make them auto detect their ip addresses?
  • 0

#6
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
right click your my network places.
click properties
right click the lan connection and click properties
select tcp/ip from the list and click properties
make sure it is set to detect your ip automatically
  • 0

#7
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Also, do you have a router or a hub?? In your first post, either you named two devices you have, or you called the same one both names. Please clarify. Also, you said that you have the cable plugged from the Modem to the "UPLINK" port on the router. Do you have a WAN port on the router also?? If so, that is the port the modem needs to be connected to.

Greazy Mcgeezy
  • 0

#8
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
it is a hub. and it just has that uplink port... no wan port..

-Josiah
  • 0

#9
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Ok, I think I know what is going on here. Your modem is assigning 1 IP address to your computer, this should be a public IP address. When you have 2 machines requesting DHCP plugged into the hub, the modem is assigning them both the same public IP address. We can fix this in a couple different ways.

1) Purchase a router, connect to the modem via the WAN port. Connect the PC's and have them obtain automatically. DO NOT USE INTERNET CONNECTION SHARING.

2) Put a second network adapter in one of the PCs. Connect the modem directly to one adapter, and with a crossover cable, connect the other two pcs. Turn ICS (Internet connection sharing) on the machine that has 2 network adapters. Then set second machine to recieve ip automatically.

Basically what we are trying to do, is take 1 public IP, and let multiple users connect. Since you are only getting that 1 IP on both of the machines, there is an IP conflict.

Greazy Mcgeezy
  • 0

#10
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
how do i turn internet connection sharing on? is it in the network setup wizard?? or?........


thanks. - Josiah
  • 0

Advertisements


#11
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
ok i figured that out...( i have them configured with the crossover cable) but now as soon as i connect them.. the internet doesnt work on either computer... but the sharing of files does.....
  • 0

#12
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
and as soon as i disconnect this crossover cable... the internet works again on this computer...( the main computer with the two ethernet jacks)
  • 0

#13
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Which connection are you sharing? You need to make sure that you have the correct network adapter using ICS. On the computer that has the 2 network adapters, find the connection that is coming into your network from the modem, that connection should be the one sharing the internet. When you enable it, you get a message that the other adapter will be set to 192.168.0.1. Click ok to accept that, then, using a second crossover cable, connect the two PCs. If the computer doesn't automatically get an IP, you should be able to click Repair in the status window of the network adapter and see if it gets one, it should. If not, follow the link in my sig to get to the Static IP Tutorial. Use it to assign the second computer an IP of 192.168.0.2 sub mask: 255.255.255.0 def gateway 192.168.0.1 DNS 192.168.0.1. See what happens.

Greazy Mcgeezy
  • 0

#14
Josiah_Fordahl

Josiah_Fordahl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
hey thanks for all your help!!! i just finally got a router.. and set everything up... and it works!!! you were a lot of help! thanks! - Josiah

how do i become as knowledgable about networks as you? did you go to college and stuff or??? thanks...
  • 0

#15
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
ITT
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP