Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Why does W98 undo changes in the MBR?


  • Please log in to reply

#1
goku5z

goku5z

    New Member

  • Member
  • Pip
  • 3 posts
Hi everyone. I have dual boot on my laptop: Windows 98 and Linux. I use Grub boot loader that displays a menu with the available systems to select. I recently updated Windows 98 (from CD) because of performance problems with Win Explorer. The Windows update modified the MBR (Master Boot Record) so now Windows automatically boots up when starting the machine.

I have the Grub boot loader installed in another small partition. To enable Grub to boot the machine, and so be able to chose from a list operating systems, I modified the MBR and set the small 'boot partition' as the 'active partition'. The next time I started the machine everything seems OK, Grub works as before handling the boot process.

The problem is that if i select Windows 98 to boot up, it does undo the changes in the MBR, setting the 'active partition' the 'Windows' partition. So next time I start my laptop Windows 98 boots up automatically, instead of letting Grub to manage the boot process. How can stop Windows undoing the changes in the partition table? I checked for a boot.xxx file in C: but I didnt find anything like that.

Any help would be massively appreciated. I'm not familiar with the windows booting system. Maybe it's a very simple and known thing. Thanks.

David.
  • 0

Advertisements


#2
Chadduss

Chadduss

    Member

  • Member
  • PipPip
  • 39 posts
Have you enabled hidden files and system files? boot.ini is a system file and will not be shown if it is hidden. With the Grub prompt have you done "setup (hd0)" to install to the mbr? Just checking to see how you proceded.
  • 0

#3
goku5z

goku5z

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
>Have you enabled hidden files and system files?
Yes, I enabled hidden files but boot.ini is not there. I searched the system using the 'Find' utility but it wasn't found (only bootlog.txt and bootlog.prv).

>have you done "setup (hd0)" to install to the mbr?
I have done "setup (hd0,1)" to install the mbr in my second partition in hda (/boot). I tried also to do setup(hd0) (just in case) but it's the same.

I have also tried to disable my antivirus in case it was restablishing the MBR, but it didn't solve the problem.

I'd appreciate any other ideas you might have. Thanks.

David.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP