Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

IDE DVD ROM DRIVE INSTALL PROBLEMS


  • Please log in to reply

#1
icikle

icikle

    Member

  • Member
  • PipPipPip
  • 144 posts
i recently bought a samsung DVD ROM from ebuyer.com

i installed it alright, and the tray opens and closes as normal, however when i try to load a disk it doesnt work, and the drive doesnt appear alongside my other optical drives in my computer.

The drive doesnt appear under "my devices" and it cant be found under "add new hardware". All it doest properly is open and close, nothing else.

Somebody help me please.
  • 0

Advertisements


#2
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Howdy:

Do you have the IDE cable connected properly??

Did you jumper it properly??

Murray
  • 0

#3
icikle

icikle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 144 posts
well there was this wide thin strip that i plugged in, and a small white four pronged connector that I also plugged in. I dont know no technical terms im sorry. But they are plugged in, and ive installed several ODD before.

Are IDE components driver ready?
  • 0

#4
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
I am going to hazard you have the IDE cable backwards.. There should be a red-stripe in one side of the cable.. that red-stripe has to plug into Pin1 on the dvd-rom..

Also, is there anything else on the IDE cable (another cd-rom or hdd) ?? If there is, then one will have to be jumpered as master and one as slave!!

Murray
  • 0

#5
icikle

icikle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 144 posts
would the drive even eject if this was the case?

and how do i do this master slave thing?

and yes there is another, A CDRW, how do i jumper??
  • 0

#6
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP

But they are plugged in, and ive installed several ODD before.

View Post


I thought you've done this before???

You should have gotten a manual with your dvd.. Read it.. It should show you the jumpers and their settings..

As long as the dvd has power, the door will open and close.. If the cable is wrong, then nothing else will happen !!

Murray
  • 0

#7
icikle

icikle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 144 posts
no manual was sent, nor a cd

ive installed ODD but only on systems without a pre-exisiting OD and only during a college course.

all cabling seems to be correct and this is the third time i have checked. my previous cd-rw is the master.

what is strikingly odd is when i boot up it says new hardware found but is calling my new hardware a printer and cannot find drivers for it.???
  • 0

#8
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Then the dvd should be jumpered as the slave..

Go to the manufacturers website and download the manual and drivers/operating program for it..

Murray
  • 0

#9
icikle

icikle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 144 posts
new details!

ive jus opened it up yet again, swapped my cd rom round with my dvd rom and now my dvd is the master. my cd rom still works fine and power is still not a problem for my dvd.

However it still does not appear on my device manager list, and appears on add new hardware as a PRINTER!!!

i can only dl the drivers as a bin file and not a self extracting file thus do not know where to install the driver nor do i know if installing them will work since my computer doesnt seem to detect it correctly.

ive downloaded the manual which says three things should be connected to the rom but i can only notice two things that can possibly be connected to it and only two things are connected to my cd rom. these are the power, and the ide connectors.

i have no idea what else to do and do not think its a problem that lies within my base unit.
  • 0

#10
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Boot into BIOS and make sure the dvd is even being detected..

Murray
  • 0

#11
icikle

icikle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 144 posts
thanks for your help but ive sorted it now. It seems both Master/Slave connectors were set to master. Im officially an idiot. Thanks anyway.
  • 0

#12
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP

Also, is there anything else on the IDE cable (another cd-rom or hdd) ??  If there is, then one will have to be jumpered as master and one as slave!!

Murray

View Post


Gee.. I thought I suggested checking that!! ;)

Glad to hear you got it up and running!! :tazz:

Murray
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP