Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Paging file is gone; correspondng error at startup


  • Please log in to reply

#1
dosboot

dosboot

    Member

  • Member
  • PipPip
  • 27 posts
I'm running windows xp home edition, Service pack 2 is installed. Everytime windows starts I get this error message:

"Limited Virtual Memory
Your system has no paging file or the paging file is too small"

then the rest of the error message tells me how to change to size of the paging file.

When I go to change my page file settings I get this message:
"Windows created a temporary paging file on your computer because of a problem that occurred with your paging file configuration when you started your computer. The total paging file size for all disk drives may be somewhat larger than the size you specified."

Changing the paging file size or letting windows manage it does not fixed the problem. Also, chaning these settings and rebooting doesn't even change what the control panel "thinks" my paging file is at.

I think the problem is just that my pagefile is gone, period. I can't find any file named pagefile.sys, both using the search feature and manually searching my windows folder (hidden and system files are visibile). If I run 'system information' (start > run > msinfo32.exe) it tells me I have 737.04 MB of page file space, and the page file location is C:\windows\system32\temppf.sys, which must just be the temporary file mentioned by the error message.

I've tried going to my control panel, setting it it to no paging file (0 size), rebooting, setting up a custom sized pagefile, rebooting. Doesn't work.

I think I have looked up every microsoft knowledge base article even remotely related to paging files/virtual memory. The only ones that resemble my problem are these:
a)http://support.micro...kb;en-us;315270 says that admin privledges could cause this problem. There is only one user account on this computer, it is the administrator account, and following the instructions on the article reveals that they already have full control.
b)http://support.micro...kb;en-us;257758 says that the problem can be caused by not having enough hard drive space for the paging file. I have ~40 GB of free space.
c)http://support.micro...kb;en-us;316528 says that certain intel chipsets can cause this problem when you upgrade to windows xp. I do have one of the specified chipsets, but this problem occured spontaneously and not after after upgrading to xp (which never happened anyways, this computer came with xp installed). I followed the prescription just in case and installed the lastest version of intel application accelerator. It didn't help.

Restarting in safe mode still causes the "Limited Virtual Memory. Your system has no paging file or the paging file is too small" error message to appear at startup. The error message when I go to the control panel also appears.

I have Norton anti-virus, adaware, spybot S&D installed and fully updated. Ran all of them. Also tried running check disk and running defrag. None of them fixed the problem.

I really don't know what caused the problem. I've had this error message for years and tried several times to fix it. It is starting to drive me crazy!
  • 0

Advertisements


#2
dosboot

dosboot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts
*bump*
anyone?
  • 0

#3
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
CAUTION!

The following deals with your Registry. Before making changes to any registry value, be sure back up the Key you are working in so you can revert back to the original values (in case you mess up!)

IF YOU NEED EXACTING DIRECTIONS ON WORKING IN THE REGISTRY, PLEASE ASK BEFORE ATTEMPTING ANY EDITING! ONE MISTAKE CAN RENDER YOUR COMPUTER UNUSABLE!!!!!!!!!!!!!!

Enter the Registry editor here: Start/Run/Regedit

Navigate to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

On the right side of the Registry editor screen, find:

PagingFiles - To change the mininum and maximum values, right click/modify.

Example: C:\Pagefile.sys 758 1536

You will also need to make this change in the HKEY_LOCAL_MACHINE\System\ControlSet001, ControlSet002 and ControlSet003
branches, if they exist. Don't forget to back up the original Keys!

REMEMBER... If you need help doing this, please ask!


I hope this works out for you.
makai
  • 0

#4
dosboot

dosboot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts
Could you give me directions on how to backup the registry before I make these changes?
  • 0

#5
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Ok, check back in 10 minutes and there will be a post for you to follow.


Go to the Start menu and select Run.
Type in "regedit" (no quotes)

When the Registry editor window opens, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management by clicking on the plus signs as you go.

To back up this key, right click on the Memory management folder and select Export from the drop down menu.

A new window will open where you have to choose a destination and a name for the exported registry file. Choose your desktop as the destination, and name it memmgmt... or whatever you want. Click ok.

Check to see that the exported registry file exist on the desktop. If it is, then continue on...

On the right side of the Registry Editor window, you will see a list of entries. Find PagingFiles (AB icon), and right click on the icon.

From the dropdown list, select Modify.

Edit the values to read: C:\Pagefile.sys 758 1536 then click on Ok.

Note that you will have to do this procedure for ControlSet001, 002, 003 if they exist.

After you correct all the values, you will have to restart your computer... and hopefully this will correct your problem!

This is not a difficult procedure, but be careful you ensure you are modifying only the registy values stated. Any more questions before you begin, post back


makai

Edited by makai, 10 July 2005 - 04:58 PM.

  • 0

#6
dosboot

dosboot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts
The error message still appeared after I rebooted.
  • 0

#7
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
How much space is left on your hard drive?
  • 0

#8
dosboot

dosboot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts
26.1 GB
  • 0

#9
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Have you run "chkdsk" lately?
  • 0

#10
dosboot

dosboot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts
No, not lately.
  • 0

Advertisements


#11
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Try this..

Set virtual memory to "no page file".

Shut down the computer (not restart). Then restart it.

Delete Pagefile.sys (found in C:\)

Now set virtual memory min and max values. to 768 and 1536 respectively.

Restart the computer.


makai
  • 0

#12
dosboot

dosboot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts
I'll give it a shot but like I said I've tried that before. There isn't a pagefile.sys anywhere that I can tell.

Edit:
I followed your instructions except for deleting pagefile.sys which isn't there.

After I set it to 'no pagefile' I did not recieve the startup error message ("Limited Virtual Memory Your system has no paging file or the paging file is too small...") when I turned the computer on after shuting down, nor did I recieve the error message when I restarted after that. Once I set a pagefile size and restarted I did get the error message at startup.

Also, even though I did not get the error message at startup after the first restart, I did get the "other" error message ("Windows created a temporary paging file on your computer because of a problem...") when I go to the tab where you change the pagefile settings.

Edited by dosboot, 10 July 2005 - 06:45 PM.

  • 0

#13
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Is your hardisk partioned? Or is there just C:\
  • 0

#14
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
This is weird! How can you not have a pagefile.sys. Is your computer set up to show all system files? (accomplished in Folder options)
  • 0

#15
dosboot

dosboot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 27 posts
No, there is just one partition. Yes, the computer is set to see all hidden and system files. I've tried searching all folders too.

If I go to run>msinfo32 it says "Page File: C:\Windows\System32\temppf.sys"

As far as I can tell, this temporary page file is the only paging file on my computer.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP