Jump to content

Welcome Guest to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Feel free to browse the site as a guest. However, you must log in to reply to existing topics or start a new topic of your own, and enjoy all this forum has to offer. Additionally, if you can assist another member by sharing your knowledge, please post a reply! Best of all - Registration and all assistance, is FREE! Learn more about How it Works. Infected? Malware Cleaning Guide. What are you waiting for?
Create an Account Login to Account

Unable to connect router to one of my PCs


  • Please log in to reply

#1
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Ok, this has given me a lot of frustration these past few days, and I have almost come to the point of just giving up...then I found this forum. So if you guys could help me out here, I would be ecstatic

So I am trying to set up a router so that it connects to my computer (and the modem) downstairs, while it sends a wireless signal to my computer upstairs. If this helps, I am using SBC Yahoo! DSL as my ISP and a speedstream DSL modem. ALso for the older computer downstairs, everytime I restart, I have to click on DSL connection and login before I can even access the internet. So when I begin setting up the router downstairs, everything appears to be working (all of the necessary lights on the router are on), but I am unable to connect directly from the router to the computer. I tried pinging the router's IP address using IE, but I can't even get a login screen (where you put admin as the user name) or anything. I tried logging in through yahoo dsl anyway from PC - router - modem anyway, just to see what would happen, and I got an error 678 saying the remote computer did not respond. But at least my computer upstairs was able to get a signal from the router, which means the router is probably ok.

So just for kicks, I tried setting up my newer computer that happens to be upstairs, and tried setting it up downstairs doing the same procedure. Well, turns out most of the time I can ping the router's IP address, and messed around with the router's settings, and for a while I could get Internet access through the computer, which connects to the Linksys router, which connects to the DSL modem. woo hoo! Weird thing was I could get internet without having to log into the yahoo dsl connection program. So now I am thinking that the problem lies in the older computer. Oh and just so you know, my parents want to keep the old PC downstairs, so switching places is not really an option. But then last night, I screwed around too much with the router, and I couldnt get access through any computer. But I still have hope!

One thing about the old computer that I noticed is that it may have some sort of spyware/malware. i can't access any program through -start/programs, and I can't access my computer or control panel by going the "start" route,only way i can get into those is by getting into windows explorer. Otherwise my toolbar and icons on the desktop disappear and then reappear with nothing opening. Do you think this whole connection problem could be caused by a virus?

I am really sorry I wrote so much, but I just figured the more detailed I was, the better you could help me, and hopefully I havent confused you. If you want I could send additional info, like the ipconfig logs on the different computers.
Thank you for your time!
  • 0

Similar Topics: Unable to connect router to one of my PCs     x


#2
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
The ipconfig info would help very much. Make sure you put everything back the way it was, then run the ipconfig and see what settings are. Also, if you could get a screenshot of the status page in your router, and blank out the WAN interface settings if you feel necessary, would only recommend this if it doesn't begin with 192.168, 172.16, or 10.,.

Greazy Mcgeezy
  • 0

#3
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
yes! a response! I was just about to send back my router too, heheh.

Ok, sounds good, i will post the ipconfig logs within the hour

Also, I was able to get both computers running individually directly from my DSL modem to my computer, which I could not do with much success before. I did this by installing the Yahoo DSL software on each, and making sure the Conexant modem PCI card was inside each computer when they were connected. My hope is that IF both computers get internet (one wired, one wireless), that both will not require their own PCI modem card, because I only have one to go around.
  • 0

#4
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
I wasn't sure how many different logs you wanted, so...better safe than sorry i guess :tazz:

This is from the newer computer connected directly to the DSL modem (no router)
***Internet works fine with this setup***

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.


Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-07-E9-26-D0-E4
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.45.102
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter DSL Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 67.115.190.43
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 67.115.190.43
DNS Servers . . . . . . . . . . . : 63.200.115.40
206.13.28.12

Edited by tennisgiant21, 04 July 2005 - 07:44 PM.

  • 0

#5
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Obviously, I am typing right now when my newer computer is directly connected to the modem... but when I did try to connect from my PC to my Linksys router to the modem, I could not connect to the Internet, nor could I even ping the routers IP address to check its status

Like the last setup, yahoo DSL prompted me for the login/password info, this time I couldnt get in.

IP log - new computer --> router --> DSL modem
***Internet does not work this way***

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.


Windows IP Configuration

Host Name
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-07-E9-26-D0-E4
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.45.102
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Edited by tennisgiant21, 04 July 2005 - 07:45 PM.

  • 0

#6
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
K, now I am back on my old (and more problematic) computer. I am directly connected from the PC to the DSL modem.

IP: PC --> DSL modem
**Internet works fine***

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.


Windows IP Configuration

Host Name . . . . . . . . . . . . :
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-07-E9-C3-53-A4
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 255.255.255.255

PPP adapter DSL Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 64.170.2.178
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 64.170.2.178
DNS Servers . . . . . . . . . . . : 63.200.115.40
206.13.28.12

Edited by tennisgiant21, 04 July 2005 - 07:46 PM.

  • 0

#7
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Right now I am still on my older computer, and as expected, I am reporting that when I tried to connect PC to router to modem, I don't get internet. Also I tried pinging the router's IP to check its status (192.168.1.1), and I still could not get this to work either. Funny because in the past it has worked.

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.


Windows IP Configuration

Host Name . . . . . . . . . . . . :
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-07-E9-C3-53-A4
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 255.255.255.255

Edited by tennisgiant21, 04 July 2005 - 07:46 PM.

  • 0

#8
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Ok, looks like there could be a couple issues here. First off, the reason those computers couldn't get online, was because their IP addresses are 0.0.0.0 or 169.254.?.?. These addresses show that when you are connected this way, you aren't getting IP addresses assigned by DHCP. This is also why you aren't able to communicate with 192.168.1.1.

Here is what to do, first, unplug everthing except for the connection between the PC and the router. Make sure that it is attached into one of the ports labeled 1-? Then, on your PC, open the command prompt, type; ipconfig /release press enter, then type; ipconfig /renew press enter. See if it gives you a 192.168.?.? address. If it does, you should now be able to access your router's web interface to configure it properly.
Make sure your modem is plugged into your router's WAN(internet) port. Then, make sure that the router's interface is set to PPPoE, enter your username and password and the information that it asks for. Once you save the changes, you should now be able to access the internet.

If this works, it will completely eliminate the PCI modem card.

If this doesn't work, you will need that card, plus the ethernet card, and the router will be used, but not as a router. But we will worry about that once you have tested those steps.

Greazy Mcgeezy
  • 0

#9
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
When I type in ipconfig/release, DOS tells me that the IP address for adapter Local Area Connection has been released.

Then, when I type in ipconfig/renew, DOS tells me that "an error occured while renewing interface Local Area Connection: the RPC server is unavailable."

I tried pinging the router's IP anyway, but it didn't work.
  • 0

#10
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Also, I'm not sure if this is useful info to you...but a friend helped me go into the computer management folder from My Computer properties, and then into services...and it turns out that the DCOM server process launcher has started, but the DHCP Client has not started, and when I try to start it, I get an error 1068.
  • 0

#11
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Follow the link in my sig to assign the following addresses to your machines:

192.168.1.100 pc1
192.168.1.101 pc2, and so on.

If your router is 192.168.1.1, then the pc should be able to see it after this. If so, enter the router's address as the default gateway on each machine.

Greazy Mcgeezy
  • 0

#12
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Ok, I'm getting excited :tazz:

I followed your directions and now I am able to connect to the router with my older PC. Here are some screenshots of the status screen for the router, and also for the LAN. I also included the "advanced routing" page. It looks like the key may be changing settings on that page? But I'm not sure. So here are the screenshots, hope they show up.



And one more thing...I noticed that on the router status page, the IP address and the default gateway settings changed each time I would leave and come back.

Another note - On my newer PC, I was able to access the internet from the PC to the router to the modem without using the PCI modem card! If only this would work with the older one...anyway I think I acheived this by going to the advanced routing page and typing in the same IP and default gateway numbers I saw in the status page...but I realize this won't work all the time, since the numbers always change.
  • 0

#13
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Well, I think my screenshot images were too big to be send as attachments, so I went ahead and sent them to your email address. Hope that's okay.
  • 0

#14
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Ok, if both computers can see the router, then there is no need to add that static route. Remove that. All you should have to do, is give the machines the IP addresses that I gave you. Make sure that the default gateway is set to 192.168.1.1. Now, on each machine, if you are keeping the static addresses as I gave you, try this, instead of putting 192.168.1.1 as the DNS address for the adapters do this. The picture that you sent me of the WAN interface status page, the one that you said the IP and DG kept changing (normal for DSL, BTW), look at where it says DNS, write down both of those IP addresses and enter them in on each adapter. Then, open a command prompt and type; ipconfig /flushdns

Then try to access the internet.

Greazy Mcgeezy
  • 0

#15
tennisgiant21

tennisgiant21

    Member

  • Member
  • PipPip
  • 30 posts
Hey Greazy,

Just like to tell you that you are a god. Looked at your advice a 1/2 hour ago, and was quickly able to set up my wireless network! Old PC downstairs, newer one up in my room, just like I had wanted! Thank you so much for all your time and effort, you have seriously made my day, no, month...hehe. peace out man.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured