Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

CD/DVD ROM and CDRW Drive have disappeared


  • Please log in to reply

#1
maggiemcmahon

maggiemcmahon

    Member

  • Member
  • PipPip
  • 14 posts
Hi guys!
Hope someone can help with this as I have no idea what's happened. <_<

Only information I have is that I have an e-machines computer with original 16x DVD ROM drive. I later installed a BENQ 52x24x52 CDRW drive and everything worked fine.

All of a sudden the driver icons disappeared from my computer. I've looked under device manager and they don't appear. They are still working cause when I put a cd or dvd in them, they start to run as i can hear the whirring noise and the lights flash to say its running but the cd or dvd doesnt start playing or isn't recognised by the computer.

Hope someone can help, please! :D
  • 0

Advertisements


#2
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Have you tried to download new drivers yet? Did this start happening just after you installed service pack 2? I bet you need new updated drivers. Try installing the original ones first if you have the disk, or maybe off the windows xp disk. <_<

-=jonnyrotten=-
  • 0

#3
maggiemcmahon

maggiemcmahon

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts
Fancy meeting you here <_<

It happened before I made any changes at all. I thought it was because of the all the viruses.
This may be a really stupid question but: How do I download new drivers because I don't have the disks anymore.

Maggie


Have you tried to download new drivers yet?  Did this start happening just after you installed service pack 2?  I bet you need new updated drivers.  Try installing the original ones first if you have the disk, or maybe off the windows xp disk. :D

-=jonnyrotten=-

View Post


  • 0

#4
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Try checking here

Http://www.driverguide.com

click "member login" at the top left of the page and use

Login: driver2
Password: all

You can search for and download new drivers for free. You will probably have to know at least which brand cdrom's you have in order to download the correct drivers.

-=jonnyrotten=- <_<
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP