Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problems updating nVidia drivers


  • Please log in to reply

#1
RyGuy

RyGuy

    Member

  • Member
  • PipPip
  • 18 posts
I'm having trouble updating my nVidia drivers for the first time ever on this machine. I have updated my nVidia graphics card drivers 2-3 times on this machine, with no problem. I recently went to their site to update my drivers and it said "Please make sure to read the Driver Installation Hints Document before you install this driver.", so I did... and this is what it said to do "Before installing new drivers make sure you uninstall all NVIDIA display drivers from the Windows Control Panel. Browse to the Start Menu > Windows Control Panel > Add/Remove Programs and search for "NVIDIA Windows Display Drivers" or "NVIDIA Display Drivers" and select remove.""

So, I went into Add or Remove Programs and I uninstalled 3 different versions of nVidia drivers. One that just said "nVidia drivers", one that said "nVidia nForce drivers" and one that said "nVidia nForce utilities". I was able to update my nVidia nForce drivers without a problem, but when I tried to update my nVidia graphics card drivers, this is the error message I got "The NVIDIA Setup program could not locate any drivers that are compatible with your current hardware. Setup will now exit.". Now, this is very puzzling to me, because I have done this many times before. So, I went back to the site, and tried to install an earlier version of drivers, and also got the same message. I don't get it. The only thing I can think of is, is that I uninstalled something I shouldn't have, but the directions on their site told me to do so. That said, I have successfully updated my drivers 2 or 3 times without error before on this machine with this graphics card, and I never uninstalled anything, so I'm thinking that is probably the problem? Agh! Help!

My system specs are:
Windows XP
Athlon XP 2500 Barton
Asus a7n8x v2.0 deluxe motherboard (nVidia nForce2 Ultra400)
512mb Corsair XMS pc3200 memory
nVidia GeForce FX 5200 (Asus V9520 Magic) graphics card

edit: I just ran a program called Everest on my computer, which gives you detailed specs about your PC, and I might of found something that may be useful, under chipset > problems, it said "AGP is disabled. This may cause performance penalty." and "Current AGP speed is lower than maximum supported. This may cause performance penalty." My motherboard supports 8x AGP but it says my current AGP is only 4x, does anyone know how to change this?

Edited by RyGuy, 10 July 2005 - 08:47 PM.

  • 0

Advertisements


#2
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Nvidia updates drives for specific reasons. Unless those reasons apply to you, you shouldn't update if you can help it.

Try downloading a new copy of your previous drivers.

Next, uninstall the current drivers. Do not restart your computer.

Go into Folder options and ensure you select that all hidden/system files can be viewed.

Do a search for anything on your computer related to nvidia and delete the files. Be sure before deletion that they are in fact nvidia files you are deleting!!!

Restart your computer and when windows detects your vid card, do not allow it to install the vid drivers. Just cancel out if possible.

Go to your newly downloaded previous driver file and install it. Restart your computer and see if it fixed the problem.

makai
  • 0

#3
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
you might also take a quick look in device manager to see what windows thinks your videocard is under display
  • 0

#4
RyGuy

RyGuy

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts

you might also take a quick look in device manager to see what windows thinks your videocard is under display

View Post


I don't even see my video card in device manager. ha
  • 0

#5
RyGuy

RyGuy

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts

Try downloading a new copy of your previous drivers. 

View Post


I would, if I could remember the exact version it was. It has been awhile since I have updated my video card drivers, that's why I was updating. And to hopefully get DX 9.0c support, but that is a whole different issue.
  • 0

#6
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
under display
  • 0

#7
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Here is the nvidia driver archieve link. Peruse it and see if you recognize your older version.

http://www.nvidia.co...2k_archive.html

In any case, it may be beneficial to take a few step backwards from the latest version.

makai
  • 0

#8
RyGuy

RyGuy

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
OK guys, here is the deal. It's now 5 in the morning and I've been up forever trying to correct my system. Turns out all I had to do to install the latest nVidia graphics card drivers, was to install the latest nVidia Forceware. So, as far as that goes, that is all running like a charm.

But, in doing all of this, I've found out... through the program Everest... as I'd mentioned before, that my AGP Controller is disabled, and this is a problem. My motherboard and graphics card both support 8x AGP, so how do I enable the thing and get it working at 8x instead of 4x?

Here is the full page of info under Computer > Motherbord > Chipset:

Field Value
North Bridge Properties
North Bridge nVIDIA nForce2 Ultra 400 (Crush18)
Revision C1
Package Type 840 Pin BGA
In-Order Queue Depth 8

Memory Controller
Type Dual Channel (128-bit)
Active Mode Single Channel (64-bit)

Memory Timings
CAS Latency (CL) 2T
RAS To CAS Delay (tRCD) 3T
RAS Precharge (tRP) 3T
RAS Active Time (tRAS) 7T
Row Cycle Time (tRC) 11T
Row Refresh Cycle Time (tRFC) 12T
Command Rate (CR) 1T
RAS To RAS Delay (tRRD) 2T

Memory Slots
DRAM Slot #1 512 MB (PC3200 DDR SDRAM)

AGP Controller
AGP Version 3.00
AGP Status Disabled
AGP Device Asus V9520 Magic/128
AGP Aperture Size 64 MB
Supported AGP Speeds 1x, 2x, 4x, 8x
Current AGP Speed 4x
Fast-Write Supported, Disabled
Side Band Addressing Supported, Disabled

Chipset Manufacturer
Company Name NVIDIA Corporation
Product Information http://www.nvidia.com/page/mobo.html
Driver Download http://www.nvidia.com/drivers

Problems & Suggestions
Problem AGP is disabled. This may cause performance penalty.
Problem Current AGP speed is lower than maximum supported. This may cause performance penalty.


edit: something must of not sat well with Windows Media Player after my update, because all of my movie files are distorted, I can see them, but they're very bright and the color is completely off. Ugh... one problem after another.

Edited by RyGuy, 11 July 2005 - 05:00 AM.

  • 0

#9
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
AGP disabled seems to be common for your motherboard (google groups search "agp disabled A7N8x").

A lot of users say they installed bios, video, and motherboard drivers and still see AGP disabled.

Do you have System Restore enabled on your computer? Maybe you should restore to an earlier date. At least you could then check if this is really a driver problem.

I'll keep reading the groups to see if I can find some answer for you.

By the way, you did enable 8x in bios, right?

Adjust the Overlay for your media player files.

makai

Edited by makai, 11 July 2005 - 09:23 AM.

  • 0

#10
RyGuy

RyGuy

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts

AGP disabled seems to be common for your motherboard (google groups search "agp disabled A7N8x").

A lot of users say they installed bios, video, and motherboard drivers and still see AGP disabled.

Do you have System Restore enabled on your computer?  Maybe you should restore to an earlier date.  At least you could then check if this is really a driver problem.

I'll keep reading the groups to see if I can find some answer for you.

By the way, you did enable 8x in bios, right?

Adjust the Overlay for your media player files.

makai

View Post


I disabled system restore, because according to a lot of my friends, it slows down your pc.

I didn't build my computer, I had someone build it for me. I am not sure if he enabled 8x in BIOS. I am pretty sure the guy is dead that built it, so I don't think I'll be able to ask him any time soon.

How do I adjust overlay? I have media player 10, I'm not seeing it.
  • 0

Advertisements


#11
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
You need to enter bios to verify your AGP settings. Just keep tapping the delete key as the computer starts up... before it gets to any Windows screen.
Once in bios, scan over the menus and look for AGP stuff. Somewhere in there you should be able to enable 8x.

Overlay is adjusted in Display Properties. Open Display properties>Settings>Advanced. Look for a tab that says Overlay. If no tab is present, then it's probably in the Nvidia tab.

makai
  • 0

#12
RyGuy

RyGuy

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts

You need to enter bios to verify your AGP settings.  Just keep tapping the delete key as the computer starts up... before it gets to any Windows screen.
Once in bios, scan over the menus and look for AGP stuff.  Somewhere in there you should be able to enable 8x.

Overlay is adjusted in Display Properties.  Open Display properties>Settings>Advanced.  Look for a tab that says Overlay.  If no tab is present, then it's probably in the Nvidia tab. 

makai

View Post


I checked BIOS, 8x AGP is enabled. So, I don't know what is causing that.

Are you talking about start > settings > control panel > display > display settings > advanced? If you are, there is no overlay tab present. I looked at my nVidia settings in my taskbar and didn't find it there, either.

Edited by RyGuy, 11 July 2005 - 11:55 AM.

  • 0

#13
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Just right-click on your desktop and select properties... it will take you to the Display Properties screen faster than going through Control panel.

Look through the Nvidia properties for adjusting your Display Colors. On the same tab, there should be an option to adjust Overlay. Note that this adjustment may be grayed out until you are actually running an mpeg video file, so run one, minimize it, then go into Display properties.

I have just changed out my nvidia card and replaced it with an ATI card, so I cannot exactly tell you on what tab to find the overlay control. If you look through every tab and option and still cannot find it, I will reinstall my Geforce and tell you exactly which tab it's on.

makai
  • 0

#14
RyGuy

RyGuy

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
OK, what I did was, I went into nVidia settings > color correction and then I changed my desktop settings to overlay. It was harder to find that it sounds. Anyway, what I did was, after tinkering around a little with Brightness, Contrast & Gamma... I just went to the overlay settings and changed the color profile from Standard mode to Advanced mode. It fixed the problem instantly. I didn't even have to bother with setting any levels, turns out... all I had to do was change the mode. ha

Now the only problem is 4x AGP, but I am just happy everything seems to be working now. If you find out anything about being able to change to 8x AGP, let me know.
  • 0

#15
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Thankyou... I was really hoping I wouldn't have to install my Geforce again... although, I do like nvidia over ati!!!

Your 8x Agp problem looks to be more complicated than it appears on the surface. It got too many hits on google groups which means it is something common and may be motherboard/driver related. Unfortunately, mb manufactures are not normally willing to admit problems with their hardware, so hopefully nvidia will step in to try to fix the problem.

makai
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP