Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Failed SP2 install

  • Please log in to reply




  • Member
  • PipPip
  • 54 posts
Hey everyone,

I'm currently trying to clean out someone's computer for them, it's filled with malware and viruses.

I've run lots of scans in Ad-aware and avast! and they both keep turning up more and more stuff. I think I've got rid of most of it, but I need to patch the computer and 'educate' the users so that it doesn't happen again.

The problem lies therein. The main reason the viruses are getting in is because the system is completely unpatched. I've brought along an SP2 installer CD with me and have been trying to install that (because Windows Update is stuffed - it hangs on the 'updating software' bit.)

After performing inventory and basically prepping the system for install, SP2 installer gives me this error:
Posted Image
...followed by this screen when I click OK:
Posted Image

And here's the last few lines in \windows\svcpack.log:
78.953: OEM file scan used 29671 ticks
166.672: c:\windows\system32\drivers\mdmxsdk.sys is in the list of oem drivers...skipping copy!
166.672: c:\windows\system32\mdmxsdk.dll is in the list of oem drivers...skipping copy!
209.907: AnalyzePhaseOne: used 160625 ticks
209.938: AnalyzeComponents: Hotpatch analysis disabled; skipping.
209.938: AnalyzeComponents: Hotpatching is disabled.
209.938: FindFirstFile c:\windows\$hf_mig$\*.*
214.297: AnalyzePhaseTwo used 2969 ticks
214.297: AnalyzePhaseThree used 0 ticks
214.297: AnalyzePhaseFive used 0 ticks
214.422: AnalyzePhaseSix used 125 ticks
218.250: Trying CheckVLKForBlock again
218.766: Error: CheckVLKForBlock failed
219.125: Inventory complete: ReturnStatus=536741199, 195640 ticks
219.203: Num Ticks for invent : 195718
231.657: UnRegisterSpuninstForRecovery, failed to delete SpRecoverCmdLine value, error 0x2
231.657:  DoInstallation: Failed to unregistering spuninst.exe for recovery.
231.703: An internal error occurred.
275.407: Message displayed to the user: An internal error occurred.
275.407: User Input: OK
275.422: Service Pack 2 installation did not complete.
277.750: Message displayed to the user: Service Pack 2 installation did not complete.
277.750: User Input: OK
277.750: Update.exe extended error code = 0x1ffe054f
277.750: Update.exe return code was masked to 0x643 for MSI custom action compliance.

If someone can help me out I would be extremely appreciative. Been googling all over for the answer to this problem and I just can't find it. :tazz:
  • 0





  • Banned
  • PipPip
  • 79 posts
Usually spyware causes problems with installing SP2. I suggest you post a HJT log in this forum
  • 0



    New Member

  • Member
  • Pip
  • 1 posts
Hello All,
I am getting the EXACT error now :whistling:
please please please help me
  • 0



    Tech Staff

  • Technician
  • 16,645 posts
Hi splintax...

Are you turning off your Anti Virus application when you try to install SP2? Some AV programs will prevent SP2 from installing.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP