Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works


  • Please log in to reply

Dam Right

Dam Right


  • Topic Starter
  • Member
  • PipPip
  • 12 posts
when i do click on driver details for my monitor it tells me 'No driver files are required or have been loaded for this device'
couold this be the problem?
so many questions.....
  • 0




    New Member

  • Member
  • Pip
  • 1 posts
Hi Dam right

I had the same problem, and found it terribly annoying. Every time I was playing Half-Life 2 or Doom 3, the game would suddenly switch to XP notifying me that my gfx card was running too hot.

I found a solution, though. I downloaded a utility called Atitool (http://www.techpowerup.com/atitool/), which is basically an overclocking utility for ATI cards. Since this card is so fast, it's not (yet) necessary to start overclocking it, I know, but the Atitool also allows you to regulate the fan speeds on your X850XT-PE (start the programme, go to Settings, then to fan control).

For some obscure reason, I found that the factory settings's fan speeds were ridiculously low. Below a temperature of 90 degrees Celcius, the fan would rotate at 5% (!!!) of its capacity. Only at 91 degrees the fans would be used properly, which explains why ATI's control center told you this was the max temp).

So, what I did was change the settings to my own liking (tick 'Override fan speeds' and choose 'Dynamic based on GPU temperature'), namely -and here's the list-

above 0° at 40%
above 45° at 45%
above 50° at 55%
above 55° at 65%
above 60° at 75%
above 65° at 85%
above 70° at 95%
above 75° at 100%

With these settings I played Doom 3 at Ultra Quality and 1600*1200 without exceeding temperatures between 75 and 80 degrees Celcius, and Half-Life 2 crancked up to the max without exceeding 75°, or Rome - Total War without exceeding 70°, all for several hours in a row. All these temperatures are obviously a lot better for your gfx card's health than the 90 to 100 degrees it heated up to at factory settings.

So, I'd say, play a bit with the Atitool utility, make sure you set the programme to load at Windows Startup ('Settings' - 'Startup'), and when ATI's control center prompts you again that the safe temperature is being exceeded at 65°, tick the option not to ever give you this message again. This last thing is important, because you will exceed 65° regularly but you won't burn your gpu anymore.

Oh yeah, one more thing: on Startup, check whether Atitool's settings haven't reset (this happens sometimes) and enjoy the sound of your gfx card's fan ;-)

Hope to have been of help,

  • 0



    New Member

  • Member
  • Pip
  • 7 posts
my cousin is a computer genius he told me that when u update or switch drivers u should get proffesional help-advice cause some drivers are just fakes filled wit spyware.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP