Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Internet explorer


  • Please log in to reply

#1
Raddad50

Raddad50

    New Member

  • Member
  • Pip
  • 3 posts
I can't log into any secure internet pages. I can go anywhere on the internet until I try to log onto a page with a password. I get an error message ( Page can't be displayed or can't find page) I spent 2 hours with the Earthlink people last night and they finally said there is a problem in my browser?

Thanks for any help, Rick
  • 0

Advertisements


#2
retrac

retrac

    Visiting Staff

  • Member
  • PipPipPip
  • 578 posts
Try the following advice from chetnet.co.uk:

Open Internet Options.

Clear the Secure Sockets Layer (SSL) slate and AutoComplete history. To do so:
Click the Content tab.
Under Certificates, click Clear SSL Slate.
Click OK when you receive the message that the SSL cache was successfully cleared.
Under Personal information, click AutoComplete.
Under Clear AutoComplete history, click Clear Forms. Click OK when you are prompted to confirm the operation.
Click Clear Passwords. Click OK when you are prompted to clear all previously saved passwords, and then click OK two more times.
Verify that Internet Explorer is configured to use SSL 2.0 and SSL 3.0. To do so:
Click the Advanced tab.
In the Settings box, under Security, click to select the Use SSL 2.0 and Use SSL 3.0 check boxes (if they are not already selected), and then click OK.

Verify that the Date and Time Settings on Your Computer Are Correct
To verify that your computer is configured with the correct date and time settings:
Click Start, and then click Control Panel.
Click Date, Time, Language, and Regional Options, and then click Date and Time.
Click the Date & Time tab.
Make sure that the date and time settings are configured to use the current date and time, and then click OK.

Verify that Your Computer Is Using 128-Bit Encryption
To do so:
In Internet Explorer, on the Help menu, click About Internet Explorer.
The level of encryption on your computer appears next to the words Cipher Strength. Verify that the Cipher Strength value appears as 128-bit.
Click OK.
  • 0

#3
Raddad50

Raddad50

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thank you retrac, the advise sounds like what I did with the Earthlink people but it's nice to have it in print instead of trying to understand the people from India. I will give it a try tonight. :tazz:
  • 0

#4
Raddad50

Raddad50

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
I followed the instructions but this didn't help. Pretty much what I did with earthlink. Any other suggestions.

Thanks Rick :tazz:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP