Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows XP shutsdown incredibly slow


  • Please log in to reply

#1
urichjones

urichjones

    Member

  • Member
  • PipPip
  • 45 posts
Specs:Asus P4P800 Deluxe
1 Gb PC3200 Dual channel
Intel 3.0e HT processor
Seagate 120 Gb
Seagate 160 Gb
500 watt power supply
Soundblaster Audigy Platinum Pro


My computer is running windows xp. A week or so ago we had a power outage due to a wind storm and my computer was on at the time. A few hours later the power came back on and I turn on my computer. Another outage occurred an hour later. After that every time I click the start menu button and then the shutdown button my computer takes like 5-10 minutes before the screen dims and I get the "standby, shutdown, restart" menu. Then it takes several more minutes before I get the blue "windows is shutting down" screen and then a few more minutes before it actually turns off.

My mouse still moves but the only thing I can do after I click the shutdown button is bring up the task manager with ctrl-alt-del. From there I can choose "shutdown computer" where it skips the dimming part and takes forever at the blue "shutting down" screen.

Or if I'm impatient I can hold in the power button and power it down in 5 seconds. I don't like this option.

Booting up is quick and normal and the operations are normal. Only the shutting down sequence is slow. If I log out it goes quickly. Something got corrupted, but I don't know where to look.


Could it be a corrupt process or registry entry? If anyone has any ideas I'm open to suggestions. Also if you need more information about the computer layout other than what I supplied above let me know.
Thank in advance,

Urich

EDIT: I found a solution go to post #8.

Edited by urichjones, 21 July 2005 - 04:37 AM.

  • 0

Advertisements


#2
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
Try this Registry Tweak.

Start Regedit and navigate to the following key:
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
Set ClearPageFileAtShutdown value to 0.
  • 0

#3
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
start > run, type
cmd
<enter>

at the prompt, type

chkdsk /r
enter

say yes to chkdsk at next startup

then reboot....go for a drive, it will take an hour...

windows will then reboot. Turn it off. Shut down properly now?
  • 0

#4
urichjones

urichjones

    Member

  • Topic Starter
  • Member
  • PipPip
  • 45 posts
Thanks Darth Ash for your quick response! I applied the tweak and after a reboot everything seems to be fine! Thanks. :tazz: Wow, I didn't think it was going to be so simple to fix! Thanks again!

Just out of curiosity, why did that tweak help? I'm assuming the tweak turns off clearing the pagefile, correct me if I'm wrong. Why does it need clearing in the first place, can't the info in it just be overwritten as needed? It's stored on the hard drive right? And not in memory? I'm just trying to understand the problem a little better. Any info would be great.

Thanks,

Urich
  • 0

#5
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
U may want to clear it if, there are multiple users using the same PC. It may be possible for an expert (cause its in pure binary) to view ur pagefile and hence, he may be able to retrive some secured info.
As far as i know, it is cleared for security reasons.
  • 0

#6
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
I'm somewhat surprised that helped, to be honest....what that did is told windows NOT to set inactive page file bits to zero...so, Windows is not during shutdown "erasing" the pagefile.

That will speed it up, but why was it taking so long to do that, which is normally a 10-20 second process.

I still think you have a file system issue and running chkdsk would be advisable
  • 0

#7
urichjones

urichjones

    Member

  • Topic Starter
  • Member
  • PipPip
  • 45 posts
I went and try something. I set the registry setting back to 1 to see if the problem returned. It did. I had run chkdsk a week ago, but just for certainty I run it again today. It didn't help. I then right clicked on "my computer" and chose properties. Clicked on the Advanced and then Performance settings. From there I turned off pagefile usage. After that everything worked great again.

My question is if I turned off pagefile usage, why is pagefile.sys still on my computer? My thinking is my pagefile got corrupt somehow. I would like to delete the old one and use a new file, but if the pagefile.sys is still there and is the same size I fear windows will just use the same file.

Do you know how to correct this?

Thanks,

Urich

EDIT: I realized earlier when I stated I had turned off pagefile usage I actually had not. I hadn't clicked "set", only ok! Now I have really turned off my pagefile, but unfortunately I'm still having the same problem. I mistakenly thought the problem was solved earlier because if I shutdown right after logging in I don't have the problem. Some time has to pass, I'm not exactly sure how long, before I get the slow shutdown. I'm kind of stumped. Any suggestions?

Edited by urichjones, 20 July 2005 - 09:37 AM.

  • 0

#8
urichjones

urichjones

    Member

  • Topic Starter
  • Member
  • PipPip
  • 45 posts
mbounce.gif Woo hoo!!!mbounce.gif

I think I solved it! I have to thank RoxieVelma for tipping me in the right direction! After reading her post I opened eventvwr.msc and clicked on system and found the same error about The server {9B1F122C-2982-49E1-AA8B-E071D54F2A4D}did not register with DCOM within the required timeout except mine had a "1" and not an "I". I double clicked on the item which gave a link for more information! It asked for permission to send some info and I clicked ok. I then got the help and support center with some details which directed me to this registry key HKCR\Clsid\{9B1F122C-2982-49E1-AA8B-E071D54F2A4D}. I noticed it referred to an AppId {653C5148-4DCE-4905-9CFD-1B23662D3D9E}. I open up FIND from the EDIT menu and typed in the AppId. I found several referrals, but stopped at HKLM\Software\Classes\AppID\{653C5148-4DCE-4905-9CFD-1B23662D3D9E} where it referred to Windows Automatic Update. This got me curious so I tried to open windows update website. When I got there I was asked to download and installed an update for windows updater. I then got the normal Express and Custom options. I clicked Custom and I got an error saying I couldn't access the server or something. I noticed an error message at the upper right that said 0x800A01AE error. I went to the update troubleshooter and typed in the error. It brought up a set off instructions:

When accessing the Update site, you receive the 0x800A01AE error. Last updated : 06/07/2005 Print | Close

Problem description
This issue may happen if the current session of Internet Explorer has cached an older version of Wuapi.dll

Applicable operating systems

Windows 2000
Windows XP
Windows Server 2003

Resolutions
1. Re-register the Windows Update DLL with the commands below
Click Start, click Run, type cmd, and then click OK.
Type the following commands. Press ENTER after each command.

regsvr32 wuapi.dll
regsvr32 wuaueng.dll
regsvr32 wuaueng1.dll
regsvr32 wucltui.dll
regsvr32 wups.dll
regsvr32 wups2.dll
regsvr32 wuweb.dll

Attempt to run Windows Update


After running the instructions I was able to access windows updates PLUS my computer shutdown normally again!!!!!

RoxieVelma I hope this solution works for you too!

Thanks for everyone's help,

Urich
  • 0

#9
VinnyS

VinnyS

    New Member

  • Member
  • Pip
  • 1 posts
Thanks for posting this info, I am having a very similar problem with a customer's machine and will try these suggestions.
  • 0

#10
TigerUpperCut

TigerUpperCut

    New Member

  • Member
  • Pip
  • 1 posts

[color=blue]I then right clicked on "my computer" and chose properties. Clicked on the Advanced and then Performance settings. From there I turned off pagefile usage.


I did

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

nothing changed

than I turned off pagefile and it worked!!

I'm not sure whether does it have an effect or not but ClearPageFileAtShutdown is still 0 value.

10x anyway...
  • 0

#11
timmon

timmon

    New Member

  • Member
  • Pip
  • 1 posts
Thanks urichjones for Your solution. I had the same problem.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP