Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Cannot Start OLEAUT32.DLL in Windows 98


  • Please log in to reply

#1
jascol97

jascol97

    New Member

  • Member
  • Pip
  • 1 posts
I have been making small programs in VB 6.0 for several years. I recently started working on a machine running XP (was working on a 2000 machine). When I had been working on Win2000, my programs compiled and ran fine on Win98, Win2000 and WinXP. When I started building my programs on the Win XP machine, they will no longer work on the Win98 machines that I have access to.

Initially when I started the programs on the Win98 machine, I got the error " Run-time error '50003': Unexpected Error".

So I ran the installation program that VB 6.0 makes with its Package and Deployment Wizzard to update the files. When the OLEAUT32.dll gets updated during the installation from version 2.40.4275 to version 5.1.2600.2180 I get the error "The OLEAUT32.dll file cannot start. Check the file to determine the problem". That error shows up when windows starts, and when I try to start the programs.

At that point, the programs won't start and Explorer will open, but will not show anything in the window.

I have run all of the Windows Updates and the Visual Basic SP 6 and the Visual Studio SP 6. I can replace the OLEAUT32.dll with the original version and get back to the first error.

Any ideas on how to get the programs I compiled on the WinXP machine to run on Win98 machines?

Thanks!
  • 0

Advertisements


#2
Tyger

Tyger

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
Frankly it just sounds like a version conflict. Don't y ou jkust love all the little changes MS makes.
  • 0

#3
adi_c_adi

adi_c_adi

    New Member

  • Member
  • Pip
  • 2 posts
jascol97 I am having the same problem!

have the same problem with the explorer, too.

did you solve it somehow?
  • 0

#4
bragi1

bragi1

    New Member

  • Member
  • Pip
  • 1 posts
I had this problem and you can find the solution here:

http://support.microsoft.com/kb/217440

Use method #2
  • 0

#5
adi_c_adi

adi_c_adi

    New Member

  • Member
  • Pip
  • 2 posts
thanks!
  • 0

#6
Ramindu

Ramindu

    New Member

  • Member
  • Pip
  • 1 posts
Eureka....!!!!! found it

I'm sure this will come too late for you

But I’m posting hoping this will help others & might use the tip on how to solve this prob.

The same thing happened to my machine (98 not SE) when I installed a program created using VB6 on a Xp mechine ..

So this is what I did :

- I booted my machine in safe mode
- Went to windows\system directory
- Deleted file oleaut32.dll
- Then ran VBRun60.exe (VB6 runtime lib)
- Booted the machine

All was as it should be….! :whistling:


May all beings be well & happy.

Rgds

www.ramindu.go.to
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP