Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Hi-Speed USB problems


  • Please log in to reply

#1
ThunderT

ThunderT

    Member

  • Member
  • PipPip
  • 56 posts
I have an MSI KT3 Ultra-ARU motherboard which comes with both USB 1.1 and USB 2.0 connectors. I running Windows XP w/ SP2 and the enhanced USB driver is loaded as you can see in the attached screenshot (if it works - I'm pretty new to posting).

My problem is that after I connect a hi-speed USB device, lately they are randomly ceasing to operate and then re-connecting and then ceasing to operate. I am connecting my hi-speed USB devices through a powered Belkin Hi-Speed 4-port hub. I was originally having this problem when connecting the devices directly to the computer but I thought I had the problem licked when I connected a powered USB HP hub and had no issues with the devices functioning. So I figured it was some sort of power issue and I purchased the powered Belkin hub and haven't had any problems until recently.

My Hi-Speed USB devices are a USB 2.0 Micro Advantage thumb drive (128 MB), a Western Digital External HDD (80GB) and a Creative Zen Micro. I have had this disconnect issue when each of the three devices was connected to the hub. The lights on the hub actually light up to show connection and the lights go out, and then back on, and then off in a cycle. Occasionally after I have the patience to let it do this multiple times, the system "stabilizes" but it appears then I get the warning that I have hi-speed devices connected to non-hi speed ports.

I have already tried turning USB Legacy On/Off, and also in the BIOS setup there is a setting for 64/40 Emulation which I have also tried on/off. I have also uninstalled the "NEC Enhanced Driver" and let Windows reinstall it.

Any help with this situation would be greatly appreciated. I really am starting to hate the sound of USB devices connecting and disconnecting rapidly! Also, I have recently purchased Acronis TrueImage 8 and I would really like to be able to use it (the back-up process fails since the external hard drive disconnects before the image is transferred).

Thanks.

Device_Manager.JPG
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP