Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Age of empires 2 can't play

  • This topic is locked This topic is locked




  • Member
  • PipPipPip
  • 303 posts
OK, so here's the problem.

I got Age Of Empires 2, the age of kings from my friend a few months ago. He lent me the cd, and took it back yesterday. So now, I downloaded a No-Cd key from a website.

After overwriting the .exe file of Age of Empires, I tried to play it. It then gives me the error message: Age of Empires as encountered a problem and needs to close.

I then downloaded another no-cd key from a different website, and it gives me the same error.

Are NO CD keys even legal? [COLOR=red] :tazz:

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP