Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works


  • Please log in to reply



    New Member

  • Member
  • Pip
  • 7 posts
I am having problems with DirectPlay, error code 0x80004005, have tried
multiple suggestions, tried all MS solutions, have physically removed sound
card and reinstalled, have tried tweaking registry to fix this problem, now
want to completely remove any and all references to DirectX from my
computer and totally reload. How do I do it? Help please! <_<
  • 0





  • Retired Staff
  • 11,413 posts
Let us take a closer look at what is running on your PC. We'll need you to use a free diagnostic tool (HiJackThis) and post a log back here with the results.

Click the HijackThis Guide in my signature, download it and follow the instructions in the guide.

Most of what it lists will be harmless or even essential, DO NOT delete or modify anything yet! Someone will be along to tell you what steps to take after you post the contents of the scan results.
  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
OK... have completed the following:
Installed and run: Adaware Se, deleted all items found
installed and run: SpywareBlaster to prevent any further spyware
Updated and installed all Critical Updates from MS
Installed and run HijackThis
These are the steps that I have taken to this point. Have physically removed and
reinstalled SoundBlaster Live sound card and software. Have reinstalled and
activated OS (XP Home SP1). I use a Labtec Axis-102 Headset, which I have
removed and replaced with a known good mic and speakers. I have searched the
web for "DpvSetup.exe" and gone thru numerous web pages on this error to
no avail. (also how I found this Web Site!) I have tried MS website and done what
they sd to do with no satisfaction. I have tried tweaking registry as suggested on
another thread on this site to no avail (see Error 0x80004005).
Here is the log from Hijack:

Logfile of HijackThis v1.98.2
Scan saved at 2:21:01 PM, on 11/8/2004
Platform: Windows XP SP1 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

Running processes:
C:\Program Files\McAfee\McAfee VirusScan\alogserv.exe
C:\Program Files\McAfee\McAfee Shared Components\Guardian\CMGrdian.exe
C:\Program Files\McAfee\McAfee Shared Components\Instant Updater\RuLaunch.exe
C:\Program Files\Messenger\msmsgs.exe
C:\Program Files\McAfee\McAfee VirusScan\Avsynmgr.exe
C:\Program Files\Creative\SBLive\Diagnostics\diagent.exe
C:\Program Files\McAfee\McAfee VirusScan\VsStat.exe
C:\Program Files\McAfee\McAfee VirusScan\Vshwin32.exe
C:\Program Files\Common Files\Network Associates\McShield\Mcshield.exe
C:\Program Files\McAfee\McAfee VirusScan\Avconsol.exe
C:\Program Files\McAfee\McAfee VirusScan\Webscanx.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Program Files\HiJack\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.gci.net/
O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
O4 - HKLM\..\Run: [Alogserv] C:\Program Files\McAfee\McAfee VirusScan\alogserv.exe
O4 - HKLM\..\Run: [McAfee Guardian] "C:\Program Files\McAfee\McAfee Shared Components\Guardian\CMGrdian.exe" /SU
O4 - HKLM\..\Run: [diagent] "C:\Program Files\Creative\SBLive\Diagnostics\diagent.exe" startup
O4 - HKLM\..\Run: [UpdReg] C:\WINDOWS\UpdReg.EXE
O4 - HKCU\..\Run: [McAfee.InstantUpdate.Monitor] "C:\Program Files\McAfee\McAfee Shared Components\Instant Updater\RuLaunch.exe" /startmonitor
O4 - HKCU\..\Run: [MSMSGS] "C:\Program Files\Messenger\msmsgs.exe" /background
O4 - Global Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office10\OSA.EXE
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office10\EXCEL.EXE/3000
O15 - Trusted Zone: http://www.gci.net
O15 - Trusted Zone: http://www.hitechcreations.com
O16 - DPF: {0A5FD7C5-A45C-49FC-ADB5-9952547D5715} (Creative Software AutoUpdate) - http://www.creative....007/CTSUEng.cab
O16 - DPF: {F6ACF75C-C32C-447B-9BEF-46B766368D29} (Creative Software AutoUpdate Support Package) - http://www.creative....15008/CTPID.cab

The only program I use a mic for is when I fly on AcesHigh. I can hear everything
that everyone else says, and hear all game sounds, but I cannot transmit. From what I can find out seems to be a DirectX problem, but have found no solution.

I would greatly appreciate any assistance that U can provide. I am going thru
withdrawel from not flying <_<

  • 0



    Founder Geek

  • Administrator
  • 24,490 posts
Log is clear! <_<

Microsoft doesn't provide an uninstaller, but you can find one here:

When finished, install the latest DirectX from here:
  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
OK, downloaded uninstaller, had to pay $12. <_<
Cannot do anything until they send me registration code
to register........
Can get a copy of DirectX version 10 which is not available
from download or download version 9c. Any recommendations?
I appreciate your assistance to this point.
  • 0



    Founder Geek

  • Administrator
  • 24,490 posts
You had to pay $12! :D I'm so sorry. We rarely (if ever) recommend anything but free tools. <_< I had that site bookmarked -- it must have been free at one time.

9C would be my recommendation.
  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Superfoxs website forwarded me to Qwerks.com for the DirectX
uninstaller which has a free download for installer. Once downloaded
and installed program is only partially usable. Pay $12 to register
program for uninstall and they send U a registration code. Now
3 days later and I still have not received any code from these guys
beginning to feel ripped off. Partial part of program that functions will
remove DirectX 9x(any version) back to 8.1. That seemed to work
OK but still have same problem. When I run DXDIAG all it tells me
is some files are out of date. After tweaking registry, DXDIAG says
system passes all test, run Sound Wizard, and still come up with
same error. <_< Will give Qwerks another day before I start hunting
them down for my money back.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP