Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

tryed installing new vid card, comp wont post

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts
Hello, i tryed installing a radeon x800XL on my computer, it didnt work because im guessing it didnt have enough power supply, it requires a min of 300w i think my computer is 250w, so i took out the vid card and hooked the hard drive wire back in...P4. turned on my computer and everything turns on except windows just wont start up, nothing comes on, it stays blank. can anyone help me with this?
  • 0




    Retired Staff

  • Retired Staff
  • 2,089 posts
Hi and welcome to Geeks to Go. If nothing powers up at all, you may have toasted the power supply. Try replacing it (get a quality psu...)

Go here for an excellent source of information on power supplies

The sticky posts at the top are the place to start.

Edited by austin_o, 02 August 2005 - 07:44 AM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP