Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

help building my computer


  • Please log in to reply

#1
for england

for england

    New Member

  • Member
  • Pip
  • 8 posts
Please help me i am building my own computer and the power won't come on. I put the power supply into the motherboard and pluged it into the wall and nothing i do have the processor on the motherboard but no ram yet.

Also i got a different motherboard to see if it was a faulty one but still nothing and so i got a different power supply to see if that was faulty but still nothing please please please help me.

This is what i got at the moment

Abit KV7-v motherboard
NVIDIA GeForce6600 128MB DDR
AMD Sempron
Sound Blaster live 24-bit
160GB
and the power supply is a colorsit 480w
  • 0

Advertisements


#2
tenbroya

tenbroya

    Member

  • Member
  • PipPip
  • 40 posts
Just A quick point - Check the Voltage setting is set to the correct setting. (110(i think) for USA or 240 for pretty much everywhere else.

Or the fuse could have gone in the power cable to the PSU, try hooking it up to an old comuter to see if it will turn on.

At the moment that is all i can think of.
  • 0

#3
humorsavesmysoul

humorsavesmysoul

    Member

  • Member
  • PipPip
  • 49 posts
it won't do anything without ram
  • 0

#4
warriorscot

warriorscot

    Member 5k

  • Retired Staff
  • 8,889 posts
If you have a speaker attached it should be beeping if you have no ram, if not attached attach a speaker to it. The golden rule is dont try and power it up until its finished. Do you have the spacers fitted and the hsf and case fans plugged in
  • 0

#5
for england

for england

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
I have the hsf fan in
  • 0

#6
for england

for england

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Right i pluged the speakers in and they came on but the fan on the power supply did not come on also i pluged the lights and other fans on the computer in but they did not come on so the computer is getting power but some things are not coming on

Edited by for england, 31 July 2005 - 02:09 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP