Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Missing XP defrag Snap-in.


  • Please log in to reply

#1
olds97_lss

olds97_lss

    New Member

  • Member
  • Pip
  • 2 posts
Does anyone know how to get the XP defragment "snap-in" back? I seem to be missing mine...

These are the two errors I get when I attempt to click on the Disk Defragmenter under Programs -> accessories -> System Tools -> Disk Defragmenter

Error 1:
Posted Image

Click ok on error 1, get error 2:
Posted Image

Any help would be appreciated. If it requires re-installing windows, don't bother typing a long winded description. If there's a quick/painless process, then by all means, share it with me.

Thank you.
  • 0

Advertisements


#2
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Amazing what Google finds...

Visit http://www.kellys-korner-xp.co m/xp_tweaks.htm and scroll down to
Item No. 291 (Restore Defrag Snap-In).

Hope it works for you!

makai
  • 0

#3
olds97_lss

olds97_lss

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Thanks for the help!

I tried to add the keys from the link you gave me and then it gave me a different error. This whole time it never occured to me to even try to google the KeyID... I thought those were unique to every system.

I didn't get the first error anymore, but when it went to the Console Window thing, I got a IE error. So I double checked everything I did in the registry and it all looked fine...

So, following your lead, I googled the keyID and found this: http://www.andreasro.../18/defrag.aspx

Following these instructions worked! I had to do this from the command prompt in the C:\Windows\System32 folder:
regsvr32 dfrgsnap.dll
regsvr32 dfrgui.dll

I also had to go to c:\Windows\INF and right click/install dfrg.inf.

My defrag has been busted for about a year... I've been using norton speed disk instead. It just bothered me to not have a normal defrag.

Thanks again for the help, I appreciated it.

Edited by olds97_lss, 30 July 2005 - 05:29 AM.

  • 0

#4
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Glad you got it fixed. Yes, many posters don't Google their failures, so... we do it for them! :tazz:

Thank for posting back how you solved your problem. It's always good to have this kind of helpful information for others to read.

Take care,
makai
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP