Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Cannot enable ICS error 1060


  • Please log in to reply

#1
jannie2

jannie2

    New Member

  • Member
  • Pip
  • 2 posts
When I try to set ICS I get the following message:
An eror occured when ICS was being enabled, the specified service does not exist as an installed service. Error 1060.
The registrykey [HKLM\System\CurrentControlSet\Services\SharedAccess] does not exist, I think a virus has deleted the registry entry. After a virusscan I have cleaned a backdoor and two trojans.
I'm using WindowsXP without SP2.
Can someone help me to repair this problem.
  • 0

Advertisements


#2
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
I have attached a file to resotre the Windows Firewall\ICS Service.
Extract ICS.reg file from the zip file and then Double-click on the ICS.reg to merge it with registry.
Now the Windows Firewall\ICS should be back.

I would also suggest posting a HJT log in the Malware Forum to make sure ur completely free from Malware.

Attached Files

  • Attached File  ICS.zip   1.47KB   332284 downloads

Edited by darth_ash, 06 August 2005 - 07:09 AM.

  • 0

#3
jannie2

jannie2

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Thank you very much. I could solve my problem with your ICS.reg file.
  • 0

#4
JimP823

JimP823

    New Member

  • Member
  • Pip
  • 1 posts
Hi,

I'm running Windows XP with SP2 and I have the exact same problem. I tried this fix, but the problem remains. When I run services.msc Windows Firewall/ICS is not listed. When I try to set up a shared connection I still get the error that the specified service does not exist.

My computer used to be able to share a connection, but it had a meltdown when the fan stopped working. The computer was "fixed", but I had to re-install the driver for my wireless card, the internet connection service seems to have been deleted. Please help!
  • 0

#5
Alavan

Alavan

    New Member

  • Member
  • Pip
  • 1 posts
Jim,

Reboot and look for Windows Firewall/ICS. Right click and choose Properties. XP may still complain that it can't find the associated service, but you should still be able to configure it to Start and Automatically. It might complain one more time once you click OK, but it should work.

It did for me on 2 machines (they were failed SP2, however).

- Alavan
  • 0

#6
sky_mac

sky_mac

    New Member

  • Member
  • Pip
  • 1 posts
I have the same problem here and can't find any key for windows 2003 spanish, no sp.
Can somebody help me...
thanx!
  • 0

#7
Newen

Newen

    New Member

  • Member
  • Pip
  • 4 posts
I'm also having problems with my ICS...
When i goto the advanced tab on my internet conenction under network connection all it offers me is firewall setting and no ICS anything.

Any ideas?
  • 0

#8
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
The ICS should be on one of your connections. Meaning you have more then one connection so there is a need for ICS.

Disable the connection with the sharing option then reenable it. This should put the ICS on to the other connection that you need it on. The one connected to the internet. ICS does not know which connection is connected to the internet.

Open all your connections and check out the options in all of them.
  • 0

#9
Newen

Newen

    New Member

  • Member
  • Pip
  • 4 posts

The ICS should be on one of your connections. Meaning you have more then one connection so there is a need for ICS.

Disable the connection with the sharing option then reenable it. This should put the ICS on to the other connection that you need it on. The one connected to the internet. ICS does not know which connection is connected to the internet.

Open all your connections and check out the options in all of them.



I have two connection.

A wired and a wireless. Neither of which have a sharing tab and the wireless is teh main one used to connect to the internet. So i disabled the wired connection to try and make the "ICS" tab that i don't have magically appear on the wireless options (i think thats what you were saying). But, sadly it didn't do anything.

Is there some option somewhere else that needs to be enabled for the sharing tab to be existent on the network connections?
  • 0

#10
cmpm

cmpm

    Member

  • Member
  • PipPipPip
  • 561 posts
http://www.google.co... ...9US270&aq=t
  • 0

#11
Newen

Newen

    New Member

  • Member
  • Pip
  • 4 posts

http://www.google.co... ...9US270&aq=t



As if that is helpful.

i've already search the Microsoft website and i have looked around online, thats why i am now asking.

I have the two connections yet there is now ICS option under the advanced tab.

I know my computer has it since it is a Win XP function. I don't get why it isn't appearing where it is supposed to.

There are other computers in my network that almost the exact same setup and they have access to ICS qithout a problem. My only problem is that those computers are not my own and i cannot use them freely. So i would like to resolve this issue.
  • 0

#12
jeet_1618

jeet_1618

    New Member

  • Member
  • Pip
  • 1 posts
I have the same problem in windows 7. Can you plz help me? Will this file work with win 7.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP