Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

PS/2 Mouse not working


  • Please log in to reply

#16
alphanov

alphanov

    Member

  • Member
  • PipPip
  • 12 posts
Jack123

I have now checked my hardware...

This is too much of a coincidence!

My keyboard is Samsung KB3M044CPXAA
My mouse is Logitech M-S48a

Drivers currently loaded (and working) are-

Keyboard -- 5.1.2600.2180 (1st July 2001)
Mouse -- 5.1.2600.0 (1st July 2001)

Does this help any?

PM me if I can assist further,

Regards
--

Nev
  • 0

Advertisements


#17
scmishra

scmishra

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
Jack123

Here is EVEREST Home Edition Report

IRQ1 and IRQ 7 are Missing in Device Resource

I have not yet run the PC in safemode.
I shall reply later about this.




--------[ EVEREST Home Edition ฉ 2003-2005 Lavalys, Inc. ]------------------------------------------------------------

Version EVEREST v2.20.405
Homepage http://www.lavalys.com/
Report Type Report Wizard
Computer HOME (Desktop)
Generator S C Mishra
Operating System Microsoft Windows XP Professional 5.1.2600 (WinXP Retail)
Date 2005-08-23
Time 01:25


--------[ Summary ]-----------------------------------------------------------------------------------------------------

Computer:
Computer Name HOME (Desktop)
DirectX 4.09.00.0902 (DirectX 9.0b)
Operating System Microsoft Windows XP Professional
OS Service Pack -
User Name S C Mishra

Motherboard:
BIOS Type Award Modular (06/05/02)
Communication Port Communications Port (COM1)
Communication Port Communications Port (COM2)
Communication Port Printer Port (LPT1)
CPU Type Intel Pentium 4, 1616 MHz (16 x 101)
Motherboard Chipset Intel Brookdale-G i845GL
Motherboard Name Epox EP-4GLM(+) (3 PCI, 1 ADD, 1 CNR, 2 DIMM, Audio, Video)
System Memory 119 MB (PC2100 DDR SDRAM)

Display:
Video Adapter Intelฎ 82845G/GL Graphics Controller (32 MB)
3D Accelerator Intel Extreme Graphics
Monitor LG StudioWorks 552V [15" CRT] (105216843009)

Multimedia:
Audio Adapter Intel 82801DB ICH4 - AC'97 Audio Controller [A-1]

Storage:
IDE Controller Intelฎ 82801DB Ultra ATA Controller
Floppy Drive Floppy disk drive
Disk Drive SAMSUNG SV2042H (18 GB, 5400 RPM, Ultra-ATA/100)
Disk Drive ST340810A (40 GB, 5400 RPM, Ultra-ATA/100)
Optical Drive SAMSUNG CD-R/RW SW-248B (48x/16x/48x CD-RW)
SMART Hard Disks Status OK

Partitions:
C: (FAT32) 19451 MB (18858 MB free)
D: (NTFS) 14362 MB (5939 MB free)
E: (NTFS) 23799 MB (8903 MB free)
Total Size 56.3 GB (32.9 GB free)

Input:
Keyboard HID Keyboard Device
Mouse HID-compliant mouse

Network:
Network Adapter WAN (PPP/SLIP) Interface (61.2.132.136)
Modem Motorola SM56 Speakerphone Modem

Peripherals:
Printer hp deskjet 3320 series
USB1 Controller Intel 82801DB ICH4 - USB Controller [A-1]
USB1 Controller Intel 82801DB ICH4 - USB Controller [A-1]
USB1 Controller Intel 82801DB ICH4 - USB Controller [A-1]
USB2 Controller Intel 82801DB ICH4 - Enhanced USB2 Controller [A-1]
USB Device USB Composite Device
USB Device USB Human Interface Device
USB Device USB Human Interface Device

Edited by scmishra, 04 September 2005 - 11:42 AM.

  • 0

#18
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
Topic: PS2 Mouse not working
Date: 22nd AUG- 2005

So we got a 20 page report? – I was having you run EVEREST so you could get proper Name & Model Number of motherboard easier. And, so you could learn more of your system. The part that I was interested in: – Must have gotten truncated by POST Length Ruling?? – Must be a 20 page limit?


I did not see report on Hardware Resources:

IRQ-1 is PS2 Keyboard – That should have shown Keyboard – [YES] – [NO]
IRQ-12 is PS2 Mouse – That should have shown Mouse – [YES] – [NO]

IRQ-7 is LPT1 Parallel Port - & Everest may not be able to detect & show


Did you Update Operating System from WIN-98?? – To WIN2K XP Pro / OS SP –
May have some remains of WIN98?? –

OK- I re-read your Posts & you did confirm what I saw in the report that you did an Update – I do not know if ALOHANOV had updated or not –


When running EVEREST – Double Click or Right Click on every line for more info/options – There is more info to have on USB detail – Also EVEREST gives Web Links for Updates & Info


There was no printer Info – What is MFG & Model Number of Printer – USB – Parallel –


Also there was no [INPUT] info - what was indicated for [INPUT] – Mouse & Keyboard?


You have almost the very same situation as ALPHANOV had:
1- Everything fine for a long time
2- All of sudden Keyboard & Mouse Problem
3- OK using USB – (Both Keyboard & Mouse)
4- Received updates - & restored back to – prior to Updates
5- Both have Samsung Keyboard & Logitech Mouse M-S48a
6- Still did not fix
7- Then started in [SAFE MODE] & Replaced Mouse & Keyboard Drivers – and PS2 Ports were fine again –

You have done everything but the LAST STEP – [SAFE MODE] – Replace Drivers.


Should have had you try [SAFE MODE] – 1st – It uses basic drivers & would verify if PS2 Ports are functional

Looks like PCI – 0 is [VIDEO/GRAPHICS CARD] – PCI-1 is empty – what is in PCI-2 ???

Jack123
  • 0

#19
scmishra

scmishra

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
IRQ1 and IRQ2 are not visible in EVEREST report as I have uninstalled ps/2 KBD and ps/2 Mouse. Presently these two hardware are connected thru USB ports.- HID compliant Mouse and HID compliant keybaord.

I have an USB HP Inkjet Printer. No Parallel Printer.

I have dual booting OS - Win98 and Win XP pro.

Tried to run Win 98 in Safemode- No "Safemode" indication at the four corners of the screen.
Still tried to update driver for Logitech PS/2 Mouse. Error indication appeared in Device Manager against mouse. ( Reource setting at IRQ12 shown) Before this step I had disabled USB mouse support in BIOS setup and connected the mouse at ps/2 port. At next restart window did not recognise the mouse- a message appeared to this effect at the booting time.

With regards to keyboard, I am unable to disconnect from USB as there os no other pointing device and no input is possible if I connect it to ps/2 port. Still forcefully added hardware by connecting the KBD through USB port. After some time resource conflict appeared with motherboard resources.
Input/Output Range 0060-0060
Input/Output Range 0064-0064
keyoard has also shared the same I/O resources. On removing keyboard device, motherboard resource conflict has also autometically solved.
Even after these trials I am unable to get any successful result.
  • 0

#20
kjtyo4

kjtyo4

    New Member

  • Member
  • Pip
  • 2 posts
I have a computer I just got with the ps/2 ports are not working, usb work fine.
When I start the computer the lights on the keyboard light up but other than that nothing else.
the mouse the optical lense is also lit up but dosn't work. The mother board also reconizes they are there.
But it dose say 2 mouses when i only have one hooked up. Is there a way to repair this issue at all.
Other than that the computer runs very well 2.8 ghz hp compaq.
Please let me know. would puting a new ps/2 port the little shine box with the plug holes on it fix this problem.
thankyoiu
kenny.
  • 0

#21
rshaffer61

rshaffer61

    Moderator

  • Moderator
  • 34,114 posts
Direct to: Kjtyo4

Please start your own topic as this one is almost 5 years old.
Although your issue may seem similar there can be other factors that may need to be resolved.
By bumping on someone's topic it makes it confusing for the tech to understand who they are helping. This can in turn cause the wrong support to be given and can cause instability or worse to happen to your system.
Thank you for your cooperation.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP