Jump to content

Welcome Guest to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Feel free to browse the site as a guest. However, you must log in to reply to existing topics or start a new topic of your own, and enjoy all this forum has to offer. Additionally, if you can assist another member by sharing your knowledge, please post a reply! Best of all - Registration and all assistance, is FREE! Learn more about How it Works. Infected? Malware Cleaning Guide. What are you waiting for?
Create an Account Login to Account

Age of Empires 2: Can't join or host multiplayer


  • Please log in to reply

#1
FoCelestial

FoCelestial

    New Member

  • Member
  • Pip
  • 6 posts
Hello

I have a major problem playing Age of Empires online and I really need some help. Whenever I try to host a multiplayer game through "Internet TCP/IP connection" the game takes more then 1 minute to create. But when it is created people can only find the game, but they can't join it. When they try to join it they get the error message "Unable to connect".

Also, when I try to join someone elses game through "Internet TCP/IP connection" by using their IP. I can't find the game, even though I know it's there and others can find it.

I have forwarded ports 47624 TCP and 2300-2400 TCP & UDP on my router. And I have turned off my firewall completely.

I have tried uninstalling the game and re-installing it but that did nothing.

What else can I do?
  • 0

Advertisement


#2
warriorscot

warriorscot

    Member 5k

  • Retired Staff
  • 8,889 posts
Try fully DMZ ing the router thats what fixed my RTS hosting probs.
  • 0

#3
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
Everyone i know only trys the port forwarding. If you look in your router settings and find dmz host and set it correctly it will work. Noone on this site that i know of didnt even know about something called dmz host until i registered here awhile back and told them how or they saw in my pinned forums.
  • 0

#4
warriorscot

warriorscot

    Member 5k

  • Retired Staff
  • 8,889 posts
I have always dmzed my router or at least tried spent the best part of a year trying to get a rubbish voyager 205 to dmz that was an experience.
  • 0

#5
FoCelestial

FoCelestial

    New Member

  • Member
  • Pip
  • 6 posts
Okay then, two questions: If I DMZ my router, won't it make my computer unsafe against hacker attacks and the likes?

And second, what's the correct way of setting it up, because I tried doing it, and all I did was go to something called "NAT configuration" where I had four options.

Nat Configuration: Enabled/Disabled
DMZ State: Enabled Disabled
DMZ IP Address:
Interface: (My interface)

Is there anything else I should do or know?

THanks loads for the replies though and please keep 'em coming I'm desperate to solve this problem! :tazz:
  • 0

#6
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
look in my pinned forum on how to open a cod /uo server. It lists everything you ever need to know.

whatever your ip is that your router gave you, example if it is 192.168.1.1 Put this as your dmz ip address 192.168.1.100

so put 100 in the blank. If your last digits on the ip address is more than 1 leave it the same when u put it in dmz.

What is Dmz host you ask?

This feature sets a local user to be exposed to the Internet. Any user on the Internet can access in/out data from the DMZ host. Enable the feature as you wish to use special-purpose service.
  • 0

#7
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
LoL, my friend had a POS belkin router and he couldnt figure out how to set the dmz for a long time over a year and i talked him through it and got it to work in 5 mins.
  • 0

#8
FoCelestial

FoCelestial

    New Member

  • Member
  • Pip
  • 6 posts
I'm sorry but I had a bit of a hard time understanding that. My IP is 192.168.0.4 do you want me to set that as the DMZ?

I have a D-Link DSL-504 router btw :tazz:

Edited by FoCelestial, 10 August 2005 - 01:58 PM.

  • 0

#9
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
no, try 192.168.0.40 in the dmz host blank

apply those settings

my router is different but set dmz to enabled and add what i said

Edited by jrm20, 10 August 2005 - 05:41 PM.

  • 0

#10
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
if it still doesnt work re check your settings and check that all firewalls are off and for the heck of it try joining an online game on another game.
  • 0
<

Advertisement


#11
FoCelestial

FoCelestial

    New Member

  • Member
  • Pip
  • 6 posts
I tried this:

Nat Configuration: Enabled/Disabled
DMZ State: Enabled/Disabled
DMZ IP Address: 192.168.0.400
Interface: (My interface)

But I got a message saying that the address could only range from 0-255

Btw, was there anything else I needed to do? I had a hard time understanding the other things you said.
  • 0

#12
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
put 192.168.0.40 not .400 lol.

Edited by jrm20, 10 August 2005 - 06:02 PM.

  • 0

#13
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
Will it still give you the dmz option if you disable nat?
  • 0

#14
FoCelestial

FoCelestial

    New Member

  • Member
  • Pip
  • 6 posts
Just tried that and it did not work. Still can't host an AOE2 Multiplayer game. And when I disable the NAT the DMZ options just go gray which seem to indicate that it's not available without the NAt option enabled.
  • 0

#15
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,392 posts
Okay, enable dmz host put .40 in the dmz host blank. Try a different game than age of empires 2. See if you can connect to other servers on another game.
  • 0

Advertisement




Similar Topics: Age of Empires 2: Can't join or host multiplayer     x


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured