Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

TCP/IP networking problem


  • Please log in to reply

#16
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
i was afraid of that....hmm....try putting that machine's ip address as it's own gateway (sorry if this is taking a while...but i'm attempting to apply domain network structure to direct connect...)
  • 0

Advertisements


#17
walmsley

walmsley

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
That doesn't help, sorry.
  • 0

#18
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
just trying a few things here.....so...the machine's are directly connected....can't ping each other....and have statically assigned ip addresses....the gateway is theoretically irrelivent in this situtation..you've got a crossover in between them which is good...jeepers....i'm gonna call the cavalry on this one...sit tight
  • 0

#19
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP

Howdy:

Networking isn't my specialty but.. have they got both systems in the same workgroup and are they using 255.255.255.0 as the subnet on both systems??

Also, what did they use for TCP/IP addresses (192.168.181.X) ??

Murray


try doing the network setup wizard on both machines..
  • 0

#20
walmsley

walmsley

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
Yes, both are in the same workgroup and both use 255.255.255.0
The addresses are 192.168.0.1 and 192.168.0.2.
Network setup wizard doesn't seem to help.
The problem may be to do with the games themselves, as some work and some don't. But those that don't, don't in the same way, so maybe there's some way to fix all games which don't work in this way, if you understand.
Instead of automatically finding the server, it asks for an IP address, or computer name, or leave blank to search. All three I've tried, and all three failed.
  • 0

#21
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
can you ping 127.0.0.1 from the machines
  • 0

#22
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
also

  think your trying too hard here. Windows XP makes things easy.

You shouldnt need to worry about workgroups. That was only necessary for file sharing with windows 98.

As for pinging, turn off the windows firewall. Your pings will work then. Its likely that they had it enabled. Some games require 2 way communication, the firewall may have blocked incoming communication.

You cant set the gateway as 127.0.0.1 because thats the localhost IP and it will loop.

One of the machines needs to serve as the gateway. Pick one, it doesnt matter, and make that the default gateway on both of them.

Try some of those and see how you come out.

ScHwErV 


  • 0

#23
walmsley

walmsley

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
I CAN ping 127.0.0.1 from both.
One computer uses Windows Firewall (this one I also use for the internet, but as the internet uses the same ethernet port, the network is never on at the same time) AND Norton Internet Security. I disabled both, although NIS is still open, just not on. Bloody annoying, too, that it keeps reminding me that it's not on. And the other one doesn't have a firewall on anyway.
I made one the gateway, and then tried pinging. The computer without the firewalls could ping the one with, although the one with could not ping the one without.
  • 0

#24
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
turn off the firewall and see
  • 0

#25
walmsley

walmsley

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
I've tried turning them off, although Norton won't properly close...
Anyway, turning them off doesn't seem to solve it.
  • 0

Advertisements


#26
poppo

poppo

    New Member

  • Member
  • Pip
  • 1 posts
Deleted by me, for not reading everyone else's suggestions first

Edited by poppo, 24 August 2005 - 11:39 AM.

  • 0

#27
NetworkAdmin

NetworkAdmin

    New Member

  • Member
  • Pip
  • 5 posts
Are there any Virus scanners? Norton, Macafee ect?
  • 0

#28
NetworkAdmin

NetworkAdmin

    New Member

  • Member
  • Pip
  • 5 posts
You need to make sure they are all the way closed before you try to close. Do this, because Norton could close the ports you want to use. If your not connected to the internet there is really no need for a virus scan.
  • 0

#29
walmsley

walmsley

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
Ok, I'll do my best to close Norton completely, and see if that helps.
  • 0

#30
walmsley

walmsley

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
I can't actually close the program...
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP