Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

The Windows Installer Service could not be accesse


  • Please log in to reply

#1
U_D

U_D

    Member

  • Member
  • PipPip
  • 50 posts
Ok, I get this message

The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or the Windows Installer is not correctly installed. Contact your support personnel for assistance.

Everytime I run a windows installer app.
http://support.micro...b;en-us;Q319624
that says that this doesn't work in windows xp. I have xp, and want to know how to fix it. Also, I have tried those solutions. Thanks.
  • 0

Advertisements


#2
Jarenien

Jarenien

    Banned

  • Banned
  • PipPipPip
  • 139 posts
Have you been to Windows Update in while? If not then do so because it installs the new Windows Installer 3.1 automatically.
  • 0

#3
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
We will try some simple solutions first rather than the ones in the M$-KB article.

First lets check whether you have the latest version of Windows Installer.
Open Add\Remove Programs in ControlPanel.
Scroll down to Windows Installer x.x, check if the version of Windows Installer is 3.1 (latest). If not then run Windows Update and get the latest version.


Next we need to check if the Windows Installer Service is enabled:
Start -> Run.
Type: services.msc.
Press <enter>.
Check if the StartupType of Windows Installer service is Manual. If not, double-click on it and in the newly opened properties dialog, choose [b]Manual
from the StartupType drop-down menu.
  • 0

#4
U_D

U_D

    Member

  • Topic Starter
  • Member
  • PipPip
  • 50 posts

We will try some simple solutions first rather than the ones in the M$-KB article.

First lets check whether you have the latest version of Windows Installer.
Open Add\Remove Programs in ControlPanel.
Scroll down to Windows Installer x.x, check if the version of Windows Installer is 3.1 (latest). If not then run Windows Update and get the latest version.
Next we need to check if the Windows Installer Service is enabled:
Start -> Run.
Type: services.msc.
Press <enter>.
Check if the StartupType of Windows Installer service is Manual. If not, double-click on it and in the newly opened properties dialog, choose [b]Manual
from the StartupType drop-down menu.

View Post


Both of those were set the way you said. Anything else you can think of? It's greatly apreciated.
  • 0

#5
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
Lets try re-installting Windows Installer.
Un-install Windows Installer from Add\Remove Programs.
Run Windows Update to install it again, it will be known as KB893803.
  • 0

#6
U_D

U_D

    Member

  • Topic Starter
  • Member
  • PipPip
  • 50 posts
uh... I went to windows update... and this happened


edit: just checked my update history, and it said every update was failed. I'm wondering why... should I make a new topic for that problem?

Attached Thumbnails

  • problem.JPG

Edited by U_D, 27 August 2005 - 01:47 PM.

  • 0

#7
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
For the Windows Update problem, refer the following M$-KB article:
http://support.micro...om/?kbid=811269
  • 0

#8
U_D

U_D

    Member

  • Topic Starter
  • Member
  • PipPip
  • 50 posts

For the Windows Update problem, refer the following M$-KB article:
http://support.micro...om/?kbid=811269

View Post


yea... I was usuing IE for that, but normally I use FF So sadly that doesn't help any.
  • 0

#9
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
Did you try Method2 in that link
  • 0

#10
U_D

U_D

    Member

  • Topic Starter
  • Member
  • PipPip
  • 50 posts
Yea, just noticed that >< thanks I'll try that now
  • 0

Advertisements


#11
U_D

U_D

    Member

  • Topic Starter
  • Member
  • PipPip
  • 50 posts
Um... there was no WUTemp folder, and I renamed the windows update folder, but none of those helped. Any ideas?
  • 0

#12
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
Open Add\Remove Programs in Control Panel.
Check whether tou have the following entry in there:
Microsoft .Net Framework 1.1 Hotfix (KB886903).
If not, download it from the following link:
http://www.microsoft...&DisplayLang=en.
The above update requires Microsoft .Net Framework 1.1 SP1, if you don't have SP1 for .NET 1.1, download it from:
http://www.microsoft...&displaylang=en.
If you don't have have Microsoft .Net Framework 1.1 even, download from:
http://www.microsoft...&displaylang=en
  • 0

#13
U_D

U_D

    Member

  • Topic Starter
  • Member
  • PipPip
  • 50 posts

Microsoft .Net Framework 1.1 Hotfix (KB886903).


I have the framework 1.1, but it doesn't say hotfix at the end. I ticked the show updates and didn't see it.
  • 0

#14
U_D

U_D

    Member

  • Topic Starter
  • Member
  • PipPip
  • 50 posts
Well, this isn't the greatest situation... the hotfix uses windows installer :tazz: I still get the same error.
  • 0

#15
darth_ash

darth_ash

    Member 1K

  • Member
  • PipPipPipPip
  • 1,382 posts
Sorry. :tazz:
Download Windows Installer from the following link:
http://www.microsoft...&displaylang=en.
Then to fix Winodws Update, follow my previous instructions.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP