Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Firefox just stopped opening


  • Please log in to reply

#16
JuleGreen

JuleGreen

    New Member

  • Member
  • Pip
  • 1 posts
[My Problem]
I had the same (or at least very similar) problem.
In my case, I installed "UserAgrent Switcher" to "disguise" my firefox once.
I believe that this extension made something inside the browser stuck in loop-y pothole, and the warning message that you mentioned above pops up, and Firefox is a no-show. ;)

I believe firefox kinda fooled (or identified) itself as it was MSIE while calling for some functions internally or vice versa.
(FireFox self-hypno-ed itself to be MSIE! A case of identity crisis? :tazz: ^_^)



[My Solution]
In a nutshel, enter the following line in [prefs.js].
user_pref("general.useragent.override","");

However...
I have used many versions of mini-Mo, from Firebird to Firefox, and many upgrades in between them so far.
I also have Mozilla, and Netscape browser.
As a result, I have many js/installation/Profs files that are here, there, and everywhere.
Choose wisely.

[Don't]
Don't delete Java.
There is no reason to delete Java directory as mentioned above.
(You have to reinstall JAVA again if you do)

Don't Rename or delete Mozilla directory.
It may reinitialized your extensions, settings, prefs, profiles, and/or destablized the program entirely.

[Do]
Always make backup of any file you want to edit BEFORE you change anything in it.

All you have to do, given that your problem is exactly same as mine, is locate current [prefs.js] file and enter the following line at the end of it.
user_pref("general.useragent.override","");

This will override browser identity crisis.
Don't forget to change back your useragent (AKA Browser ID) back to default once you have firefox on.
  • 0

Advertisements


#17
stardust05

stardust05

    New Member

  • Member
  • Pip
  • 2 posts
I tried this, and I added the string to the end of prefs.js, but still got the same error message. This all happened after installing UserAgent Switcher. I'm getting sick of IE, I want my Firefox back!

Other things I've read say to delete the same line from prefs.js, but I don't have this line.

Any help?
  • 0

#18
stardust05

stardust05

    New Member

  • Member
  • Pip
  • 2 posts
Never mind. I figured it out.

Thanks, this helped a lot. :tazz:
  • 0

#19
ZeN

ZeN

    New Member

  • Member
  • Pip
  • 1 posts
I also had the same problem... however, mine was fixed much easier...

Opened the taskmgr and located the firefox.exe running and killed it.

Relaunched normally...

Thanks for the suggestions,
-Z
  • 0

#20
suckaf00

suckaf00

    Member

  • Member
  • PipPip
  • 23 posts

I also had the same problem... however, mine was fixed much easier...

Opened the taskmgr and located the firefox.exe running and killed it.

Relaunched normally...

Thanks for the suggestions,
-Z

View Post


Yup, that one happens all the time!
  • 0

#21
pcontour

pcontour

    New Member

  • Member
  • Pip
  • 2 posts
It's the UserAgent Switcher,

for those who area really stuck, and are getting the message "Java Plun-in for Netscape Navigator should not be used in Microsoft internet explorer. Please use Java Plug-in for Microsoft Internet Explorer instead.

The Netscape browser thinks that it is IE during the startup where usually it always reverts back to a Netscape browser after you use the User agent switcher. I'm going to post into the User Agent switcher forum if there is one.

In the mean time further up you have a fix. Rename the firefox directory then reinstall. copy back your profile and you are all set.
  • 0

#22
pcontour

pcontour

    New Member

  • Member
  • Pip
  • 2 posts
How to Fix the User Agent Switcher

#6 Saturday, September 18, 2004 6:02
maypo
Guest Re: User agent switcher has prevented firefox from loading
Here's a straightforward way of fixing the firefox startup after changing UA to IE:
- Make sure firefox is really stopped using the task manager.
- JVM is usually installed in c:\program files\java - rename "java" to something like "_java" or "java.tmp".
- Now start firefox - it should start - since JVM is not there to complain anymore
- Open useragent switcher options, change it to default
- Now close firefox
- Go back to the java folder and rename it to the original name
- Restart firefox - should work.

Cheers
Maypo

Now, I will never fool with the default setting of user agent switcher again
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP