Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Where are these graphic libraries?

  • Please log in to reply




  • Member
  • PipPip
  • 34 posts

I 'm trying to install a graphical interface for a program which i've already got to install succesfully, but the C compiler cannot find some graphical Xwindow libraries.

In the Makefile there is this entry:
gcc -o viewkel $(CFLAGS) $(OBJS) $(LDFLAGS) \
-lm -lX11

Where CFLAGS,OBJS AND LDFLAGS, are already set up in the Makefile. However, when it tries to find X11 it aborts the compilation:

The next paragraph is what i got...is a bit long, but only the last 3 or 4 lines are important, the rest are object files compiled succesfully.

gcc -o viewkel -g -DHIGHPREC -DPARM_FILE=\"/home/che/gsg2/yaehmop/viewkel/new_atomic_parms.dat\" -DX_GRAPHICS -DINTERACTIVE_USE -DINCLUDE_ADF_PLOTS -DCULL_POLYGONS -DSUPPORT_COLOR_X -DINCLUDE_BOND_VALENCE -DSUPPORT_FATBANDS -DCHATTY_SYMMETRY -DSUPPORT_FATBANDS -D_POSIX_SOURCE -DUSE_READLINE -I/mfs/4/usr/X11R6/include main.o interface.o globals.o xstuff.o genutil.o stack.o manipulate.o hierarchy.o snapshot.o fileio.o buttons.o molecule.o solid_stuff.o graphs.o prop_graphs.o band_graphs.o walsh_graphs.o graphics.o tek_lib.o help.o FMO_diags.o orbitals.o fit_orbs.o matrix_ops.o implicit_polyg.o triangles.o 3D_objects.o enhpost.o cont_plots.o contour.o labels.o MO_conts.o vibrations.o valence.o polyhed.o chull.o mem_debug.o -I/usr/include -ireadline -ihistory -L/usr/lib/ -ltermcap -L/usr/lib \
-lm -lX11
/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make: *** [viewkel] Error 1

There’s a copy of the X11 library in /usr/X11R6/lib/ directory. I've tried to add
–L/usr/X11R6/lib in many places but it is still not working :)

Can i get any help please? :tazz: (Running Red Hat Fedora)
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP