Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Winsock keeps getting screwed up - HELP please


  • Please log in to reply

#1
Cough

Cough

    New Member

  • Member
  • Pip
  • 8 posts
Ok long process to get wireless running on my desktop computer (been trying on and off for a year). I recently got wireless going well on two laptops so I thought I would try again on my desktop this week since I now knew my router and signals etc was OK.

On the desktop I could see the wireless connection, but kept getting a "limited or no connectivity" message after final connect. Lots of searching oin the internet, tried lots of registry changes on dhcpnodetype, checked ipconfig, pinged all over the place etc etc.

Finally tracked it down to Winsock corruption (which I have had before) Ran WinsockXPfix.exe - which restores Winsock values to original. Presto - finally got wireless on my Desktop. Worked fine for a couple of days. Last night I was using it fine. Shutdown the machine last night, started it up this morning, wireless wouldnt work. Ran winsockxpfix.exe again this morning. wireless works fine again. But obviously I dont want to run a program that cleans my registry every day just to get wireless.....

Any ideas why why winsock values could be getting getting corrupted? How to trouble shoot? Can I do a comparison of registry before and after to find out exactly what is changing? And no, I dont want to do a fresh install of XP to fix it.

Both laptops and desktop running XP home, SP2, current updates. One lappie running AVG, one running Norton, desktop runs Mcafee. At some point I will take Mcafee off and run AVG, but dont really want to do that yet.

ps anyone else having problems when you save the registry in winsockxpfix. It used to work fine but now wont save files without errors - maybe since SP2 or one of the updates since??
  • 0

Advertisements


#2
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
I Know of only two MAIN reasons that registry values get corrupted:

1) SOFTWARE USAGE - Frequent installation and Uninstallation of software and Incorrect procedures for Installtion / UnInstallation of software. And also frequent Freeware / Shareware software usage.

2) MALWARE / VIRUS - Lack of security and Virus Scanners.

If I were you, I would visit the the malware forum of this site and complete the steps for malware removal.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP