Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Virii gone, but it ate Wininet.dll


  • Please log in to reply

#1
Hollow

Hollow

    New Member

  • Member
  • Pip
  • 3 posts
Hi, great forum here, sorry I have to come here with a question first-off though. :)

My mother got PsGuard/Smitfraud yesterday. I've already removed the virii and ran all the malware removal programs..but it seems that during the whole process, Wininet.dll was infected and therefore deleted. I replaced Wininet.dll with one I found on the internet (at DLL-files.com I believe), which allows the computer to start..but you can't really use it.

Constant Explorer pagefaults. Module <unknown> at 0000:0043da2a

Does anyone know if this is really Wininet's fault, or something else? I was going to delete this Wininet again but I thought that'd be a bad idea. And I already checked, there are no other copies of Wininet on the system.

I ran System File Checker, it didn't say anything was lost/changed (which I found odd). I can run it from DOS perfectly, and if I'm fast enough I can shut down to MS-DOS mode before the pagefault shows up.

This is a Pentium 75 running on Win98 here, so you can imagine my frustrations :tazz:
  • 0

Advertisements


#2
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
This will rebuild rather than restore the registry

Boot the PC and keep tapping F8 right after the beep until you get options, select command prompt only, type scanreg.exe /fix then press enter, it will run through a few screens then say registry repaired. Press enter then press ctrl + alt + delete keys together to reboot.
  • 0

#3
Hollow

Hollow

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Alright, did as you said. :tazz:

Pagefaults still happening though, but the number changed to 0000:00437c0e
  • 0

#4
Tyger

Tyger

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
Hellos Hollow, in this version of win98SE the wininet.dll is located in win98, the cabinet file #44, If your installation files are on your hard disk or you have the cd you should be able to extract it from there, you should also be able to replace it with system file checker using the replace function.
  • 0

#5
Hollow

Hollow

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Awesome, pagefaults are gone. Thanks for telling me which cab it was. :tazz: Outlook Express 5 refuses to open though, pagefaults. Internet Explorer also is acting strange..back and forward wouldn't work, "invalid argument". After shutting it down, IE won't work at all now, so I'm just going to download and install IE 6. Hopefully that'll clear up the rest of the problems.

Again, thanks so much, helpful folk. :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP