Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Service Pack 2 or Hard Drive failure?Really Desper


  • Please log in to reply

#1
mingul

mingul

    New Member

  • Member
  • Pip
  • 4 posts
Hello

I have just installed for 2 days Service Pack 2 for Windows XP.

Today while I was doing the windows update I started getting some yellow exclamation marks in the right corner of my screen and one of my hard drives (SATA) - I also have my system on an IDE Hard drive - started moving very slow

The messages that I got were: (found them in the EVENT VIEWER)

An error was detected on device \Device\Harddisk1\D during a paging operation.

{Delayed Write Failed} Windows was unable to save all the data for the file . The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

...
also found this

The system failed to flush data to the transaction log. Corruption may occur.


The computer restarted...and after the black startup screen with the windows logo on it hanged...I tried safe mode...the last file on the black screen was "ndisrd.sys" but still i couldn't get back to windows.

In the end the only way to get back in windows was to take the SATA out of my computer...

A friend of mine sent me a DOS based program called ACtive partition recovery...and it showed all my partitions but i didnt do anything with it because i am not very experienced...

My question is:
Is my hard drive broken? Or is it a Microsoft problem again?

Did i lose all my data?

Please answer to a desperate human being :tazz:
  • 0

Advertisements


#2
FreddieKrugerGuy

FreddieKrugerGuy

    Member

  • Member
  • PipPipPip
  • 269 posts
Welcome to Geekstogo!

Do you still have your windows xp disc? Try repairing windows using the disc. If the repair fails, reinstall windows.

(Make sure you make backup copies of crucial files if you can.)

Freddie
  • 0

#3
mingul

mingul

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
I tried reinstalling windows...but i have to press F6 in order to load the drivers for my SATA hard disk from a floppy disk, i did that...and when trying to repair before gaining full control, the windows installing setup usually analyzes the hard drives (takes about 1 sec each)

Unfortunately it stopped on the analyzing of the SATA one...and would not go further:((

My SATA is out of the computer...i cannot get windows started my any means if i plug it back in :tazz:

Edited by mingul, 04 September 2005 - 01:26 PM.

  • 0

#4
FreddieKrugerGuy

FreddieKrugerGuy

    Member

  • Member
  • PipPipPip
  • 269 posts
It may be that the SATA has said goodbye. It will most likely need to be replaced.
  • 0

#5
mingul

mingul

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Is there any chance I can save anything I have on? Are SATA recoveries possible?

I know this is ambigous but I had to ask it...

I also found these to entries at Microsoft:

http://support.micro...om/?kbid=870894
http://support.microsoft.com/kb/885464
  • 0

#6
FreddieKrugerGuy

FreddieKrugerGuy

    Member

  • Member
  • PipPipPip
  • 269 posts
I'm not sure if you'll be able to recover anything from it.

Freddie
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP