Jump to content

Free help from tech experts
Welcome to Geeks to Go forums. Create a FREE account now to gain access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing topics, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. Best of all, registration and all assistance is 100% free! This message, and all ads will be removed once you sign in.
Create an Account Login to Account

windows xp won't recognize hard drive


  • Please log in to reply

#1
ex-bubblehead

ex-bubblehead

    Member

  • Member
  • PipPip
  • 13 posts
I have just redone my system that had two hard drives, one for Windows and one for everything else (it never had a Windows installation on it). I replaced the motherboard and cpu and wound up needing to buy a new hard drive for the windows installation.

I had no problems installing Windows (XP) onto the new hard drive, but now I canít access the old drive that had all my important data on it. It does not show up in explorer. It shows up in the BIOS on boot and I also saw it in the list of partitioned drives during the Windows installation and it shows up as Active in Disk Management, but does not show up in explorer :) :tazz: .

AHHHHH!!!!!

Someone please help!
  • 0

Similar Topics: windows xp won't recognize hard drive     x


#2
Les1451

Les1451

    Member

  • Member
  • PipPipPip
  • 165 posts
Try assigning a new drive letter to the problem hard drive : Start > Administrative Tools > Computer Management > Disk Management. Right click the drive then click Change Drive Letter and Paths. Choose a drive letter that is not already in use, click OK then OK again.
  • 0

#3
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi ex-bubblehead...

Did you remember to change the jumper on the old HDD to slave? If both drives are connected to the same cable, one will have to be jumpered as a slave and connected to the center connector on the ribbon. If you use a second ribbon, it can be connected as a secondary master on the end connector of the secondary ribbon.

wannabe1
  • 0

#4
ex-bubblehead

ex-bubblehead

    Member

  • Member
  • PipPip
  • 13 posts
Thanks for the suggestions, but neither is it.

The only option I have when right clicking on the drive in Disk management is to delete the partition. As for the jumper issue, I have the drives setup on Cable Select with the Master on the black connector (end of the cable) and the slave (the drive in question) is on the grey connector (middle of the cable). I suppose I could jumper them. I will have to try that.

In the meantime, does anyone else have any other ideas?

Thanks
  • 0

#5
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
ex-bubblehead...

Some hardware configurations have trouble with Cable Select...try setting them up with the jumpers.

wannabe1
  • 0

#6
ex-bubblehead

ex-bubblehead

    Member

  • Member
  • PipPip
  • 13 posts
Well...isn't that just a fine thing. Setting jumpers didn't work. I also tried a "Repair" install of the Master drive after unplugging the data drive. Interestingly enough, it saw the Master drive as drive "c" when performing the repair but after rebooting (twice) and then reconnecting the data drive I wind up in the same boat.

The windows drive is seen as drive "F" and the data drive has no letter assigned and I can't do anything to it in Disk Management.
  • 0

#7
Les1451

Les1451

    Member

  • Member
  • PipPipPip
  • 165 posts
Right click the drive in Computer Management, select Properties,click the Hardware tab, select the drive (assuming it shows up), then click Properties. At the bottom of this window under Device Usage is the option set to Use This Device (enable) ?
  • 0

#8
ex-bubblehead

ex-bubblehead

    Member

  • Member
  • PipPip
  • 13 posts
Device shows as enabled
  • 0

#9
Tyger

Tyger

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
In Bios are both drives set to autodetect?

And something not mentioned, you have installed windows, but did you install the chipset drivers for the motherboard?
  • 0

#10
Les1451

Les1451

    Member

  • Member
  • PipPipPip
  • 165 posts
You say your system drive shows as drive F, what shows up as drives C to E ?

I have to go to work now but I'll check back here when I return.
  • 0

#11
ex-bubblehead

ex-bubblehead

    Member

  • Member
  • PipPip
  • 13 posts
Good suggestions all...

Checked the BIOS and made sure they were on Auto-detect.
Installed the chipset drivers.

No luck.

As for drive letters...last night before I went to bed I did another fresh install of XP. I disconnected the data drive for this install to ensure that only the applications drive would be recognized. I made two partitions on this drive, a Windows (boot) partition and an Applications partition. The install was successful with the Windows partition designated as the C: drive and the apps partition as the D: drive.

I connected the data drive and...same as it ever was.

Soooo...

After installing the chipset drivers, I got "Found hardware" messages for the two optical drives and also the data drive (hope, hope, hope). Went to Disk Management and what to my eyes appears?

C: Windows
D: Applications
E: CD-ROM
F: DVD
Data drive with no letter and all the same attributes as stated before. :tazz: :) :)

Thanks for all the good advice, can I just go dump this in Bill's lap and tell HIM to fix it?
  • 0

#12
Les1451

Les1451

    Member

  • Member
  • PipPipPip
  • 165 posts
This site may be of use to you, there's a diagnostic application you can download to check the status of your hard drives and a walk-through of the steps to take for troubleshooting various scenarios.
Click Here
  • 0

#13
ex-bubblehead

ex-bubblehead

    Member

  • Member
  • PipPip
  • 13 posts
Thanks for the link. No errors reported. I really didn't think there would be since every other indicator points to nothing wrong with the drive. Interestingly enough, one of the diagnostics was to check for file system integrity. The tools did not show that that drive existed. It showed the other drive with two VOLUMES and their file systems, but not the data drive.

Windows is just not recognizing that there is a volume there with information on it. I don't know what else to do.
  • 0

#14
thehumpster

thehumpster

    New Member

  • Member
  • Pip
  • 8 posts
I've been fighting the drive letter not assigned problem for several hours now until I found the following over on the Experts Exchange forum, courtesy of "truenorthtn" who wrote:

"

I had the same problem. After a bit of research I figured it out. It would appear drives that have GoBack installed will not be recognized by Windows XP due to changes GoBack makes to the MBR. The solution is to simply put the hard drive back into the old computer and uninstall GoBack. This is done in two steps. First you need to hit the Space Bar while booting to access the GoBack menu. From this menu you need to disable GoBack. Once GoBack is disabled you need to load Windows and uninstall GoBack. Worked like a charm for me. Hope this helps!


My problem is fixed now, it worked for me.
  • 0

#15
thehumpster

thehumpster

    New Member

  • Member
  • Pip
  • 8 posts
I forgot to mention to make sure to let your old drive reboot after uninstalling Goback so it can make the MBR change, then shut it down for the last time and slave it once again. Again, goodluck.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured