Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

help!


  • Please log in to reply

#1
mleo67

mleo67

    New Member

  • Member
  • Pip
  • 6 posts
hi all,
have a problem turning cpu on,no power was running into cpu,thought was power supply..had to play with power cord to get power,now i went on and order a new power supply.i'm still having the same problem,which is i have to play with power cord when i'm connecting to power supply box to get cpu on...
sometimes it works! any suggestions,help or ideas in what can be the problem. same problem with old/new power supply.
thanks!!
  • 0

Advertisements


#2
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Howdy:

Did you check the receptacle the other end of the PSU cord is plugging into??

Try a different socket or surge protector..

Murray
  • 0

#3
mleo67

mleo67

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
ive tried in many different protectors,plus cords.still the problem exits.
thanks for your help..if any other solutions would still be appreciate.
thanks!!
  • 0

#4
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Move to a different room and use an entirely different circuit and see what happens..

Murray
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP