Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

When is a pen drive a floppy disk drive?

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
When I insert a USB pen drive (I have tried four different models of varying sizes) into my usb and then double click on ‘My Computer’, the device initially shows up as ‘USBDISKPRO (H:)’ and this is then joined by ‘3 1/2 Floppy (B:). Then the first icon disappears. Neither ‘work’, in that I cannot transfer files to or from the pen drive. I had similar problems when connecting an external dual layer dvd writer. I managed to get it to work once but since then it simply causes a crash. I am running XP Home on a 2.4 GHz Pentium 4 Evesham computer with 1Gb RAM. When I contacted them for advice they suggested I reinstall Windows. I really don’t want to have to do this because of the number of programs I have installed. Does anyone have any ideas?

Details of my computer:
Operating System Microsoft Windows XP Home Edition
OS Service Pack Service Pack 2
CPU Type Intel Pentium 4A, 2400 MHz (18 x 133)
Motherboard Name Asus P4B533-VM (3 PCI, 1 AGP, 2 DIMM, Video)
Motherboard Chipset Intel Brookdale-G i845G
System Memory 1024 MB (DDR SDRAM)
BIOS Type Award Modular (05/07/02)

IDE Controller Intel® 82801DB Ultra ATA Controller
Disk Drive WDC WD1200JB-00CRA1 (111 GB, IDE)
Optical Drive DVDRW IDE 16X
Optical Drive LG DVD-ROM DRD8160B (16x/48x DVD-ROM)
Optical Drive PIONEER DVD-RW DVR-104 (DVD:2x/1x/6x, CD:8x/4x/24x DVD-RW)

USB1 Controller Intel 82801DB(M) ICH4(-M) - USB Controller [A-1]
USB1 Controller Intel 82801DB(M) ICH4(-M) - USB Controller [A-1]
USB1 Controller Intel 82801DB(M) ICH4(-M) - USB Controller [A-1]
USB2 Controller Intel 82801DB(M) ICH4(-M) - Enhanced USB2 Controller [A-1]
USB Device Generic USB Hub
USB Device HP LaserJet 1200 USB
USB Device SpeedTouch 330 ADSL Modem
  • 0


Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Click start then run, type sfc /scannow then press enter to replace the system files, you need the XP CD and get a blue bar, reboot when the bar goes

You could try removing the leads for other USB devices to see if it will run on its own
  • 0




  • Member
  • PipPip
  • 40 posts
Yeah, I agree. Try the following:

a) I assume you have tried connecting the drives in another USB port. It could be that one of your ports is faulty or a cable has gone loose (especially for front panel USB ports).

b) Lastly, verify that the device is getting enough power. You did not post your power supply information but you probably need 400W to run a P4 and devices. As Keith said, try connecting the device on its own (disconnect any other USB devices).

c) Either do the sfc /scannow command or perform a Windows Repair by booting with your Windows XP disc and selecting Install, then Repair when prompted that you already have an existing installation of Windows XP. Note that you will have to re-download most Windows updates after this.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP