Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

trouble with attrib boot.ini


  • Please log in to reply

#1
saharanz

saharanz

    New Member

  • Member
  • Pip
  • 6 posts
A couple of days a go I turned my laptop on and it stopped loading at teh blue windows xp screen. Can't load in safe mode -get same screen. Have made a boot disk and am trying to find out what the problem is but when I type 'attrib boot.ini -s -h -r' I get a message saying the parameter is not valid?
Any ideas???
  • 0

Advertisements


#2
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
You've got the syntax correct but in the wrong order --- filename should come last I believe: ATTRIB -R -S -H C:\BOOT.INI
  • 0

#3
saharanz

saharanz

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
I've tried that to but get the same response. Does it matter if the r s and h are in a different order?

Edited by saharanz, 10 September 2005 - 06:24 PM.

  • 0

#4
yardguard

yardguard

    Member

  • Member
  • PipPipPip
  • 135 posts
do em one at at time and see what happens

attrib - h boot.ini
attrib - r boot.ini

type boot.ini

if u see results then you're on your way....................
  • 0

#5
saharanz

saharanz

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
I get the same thing with 'type boot.ini'
I'll try them one at a time and see what happens, Thanks
  • 0

#6
saharanz

saharanz

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
These were the instructions I was following excpet I am using boot disks as I can't get into windows. I ahve got attrib to work ("attrib -hsr boot.ini") but edit does not work and is not in the list of avaliable commands???

Also, I tried the Windows XP repair (http://www.geekstogo...ws-XP-t138.html) but it doesn't go to the screen where it gives you the option to repair selected XP instalation. It tkaes me to a screen and asks me to choose a partition (has a big one and a little one). I choose the big one and the I get a screen that says choose:
format the partition using ntfs file system -quick
format the partition using ntfs file system
leave the current file system intact -no changes

Not sure where to go from here.


Reboot to the startup menu (where you choose Start in Safe Mode) and estart
to or exit to the prompt (in safe mode if that is an option).
You should be at the C:\> prompt.
Type:
ATTRIB boot.ini -h-s-r
EDIT boot.ini
Find the line (probably the last):
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect
and add /sos to the end of it as:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect /sos
Alt+F, Exit, Yes to save
ATTRIB boot.ini +h+s+r

If ATTRIB and EDIT give you a "not recognised command" message then use:
\windows\system32\ATTRIB boot.ini -h-s-r
\windows\system32\EDIT boot.ini

Now restart in normal mode and see if you get any suggestions from what
shows on the screen.


Disable the Windows XP Startup Screen

If you've ever wondered what goes on behind the Windows Startup Screen when
your computer boots, this will disable the screen and allow you to see
what's really happening.

Click [Start] and right click on [My Computer]
Select [Properties]
Select the [Advanced] tab
In the [Startup and Recovery] section, click [Settings]
In the [System Startup] section, click [Edit] to open the boot.ini file in
Notepad
You will see a line that looks similar to the one below

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect

To disable the Startup Screen change to line to read as below. The change is
shown in red.

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect /sos
Note: There is a space between 'fastdetect' and '/sos'
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP