Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

spoolsv.exe not starting


  • Please log in to reply

#1
weir

weir

    Member

  • Member
  • PipPip
  • 18 posts
Tried to install a printer and it keeps giving me error that it needs to be running. Its not in my running processes. I can manually start it but it only stays in processes for a few seconds. how do i add it back to running at startup

using win xp
  • 0

Advertisements


#2
meighnot

meighnot

    Member

  • Member
  • PipPip
  • 71 posts
You can change the startup type on this service by going to your Control Panel.

If you are using Classic View in your Control Panel:
Double click Administrative Tools, then double click Services.

Make sure that you click the Standard tab at the bottom on the right. Look through the list for a service called Print Spooler. Right click Print Spooler and click Properties. In the properties box, make sure that the General tab is selected, and look for the box that says Startup type:. There will be a drop-down list. You should select Automatic to have this service start when the system boots up.

If you are using Category View in your Control Panel:
You will need to click on Performance and Maintenance, then Administrative Tools, then Services.

Make sure that you click the Standard tab at the bottom on the right. Look through the list for a service called Print Spooler. Right click Print Spooler and click Properties. In the properties box, make sure that the General tab is selected, and look for the box that says Startup type:. There will be a drop-down list. You should select Automatic to have this service start when the system boots up.
  • 0

#3
weir

weir

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
went through your steps and it was already checked to automatic. Still in same spot. I must have screwed with something and dont remember it.
  • 0

#4
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
Here is what I would do
Go start < run and type chkdsk /r /x and if it asks say yes to runing it on your next boot, then reboot you computer. Will take about 1 minute per Gig if hard drive.
Go start < run and type Sfc /scannow this should fix any files that you have screwed up, it requires you XP CD and takes a while. One this is done you will have not files errors on you hard drive. Now try following the advice by the other post.

Edited by Michael Buckley, 15 September 2005 - 07:02 PM.

  • 0

#5
weir

weir

    Member

  • Topic Starter
  • Member
  • PipPip
  • 18 posts
I did as michael and meighnot suggested. spoolsv.exe was set to automatic still! i checked administrative tools>services>standard tab> spoolsv.exe and right clicked to get to its properties. It was dependent on lexbce server.

Searching on google for lexbce server i found out its a problem that comes from using a registry cleaner which tells you its a unneeded lexmark printer item and its ok to remove it. It is but you have to make it non dependent by going into start>run> and typing "sc config spooler depend= RPCSS" (make sure space between = and RPCSS)

Anyway that fixed my problem, maybe it will help somebody else
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP