Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Firefox suddenly very slow loading images...


  • Please log in to reply

#16
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
It was unlikely to be Firefox if IE6 was doing the same.

What did you have to do with the modem
  • 0

Advertisements


#17
sires6

sires6

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
I had to reset both Westell and then DLink (of course, Verizon doesn't service DLink so anytime I have to deal with them, I have to unplug my wireless router). Once I did that, they were both up working to snuff 1700 up and 600 down... By the way I painted an oil of London Bridge, love London.

annie
  • 0

#18
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Thank You for letting me know
  • 0

#19
Moto270

Moto270

    New Member

  • Member
  • Pip
  • 1 posts
I have the same thing going on. Firefox displays images slowly and IE displays them instantly. My speed test results are similar.

IE
3319 Down
353 Up

FireFox
3293 Down
354 Up

Yet it displays jpg's and images like I have reinstalled my old ISDN from way back in the day. I am looking for a solution. Just thought I would let you all know that there are people out there with ample bandwidth down and still having problems. When I first installed firefox it was actually faster than IE and that was why I really liked it. Now I can't hardly use it. I have uninstalled all of my extensions with no luck as well. I think I might try a complete reinstall to see if it changes anything.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP