Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

sharing second hard drive


  • Please log in to reply

#1
paulsiam

paulsiam

    Member

  • Member
  • PipPipPip
  • 118 posts
Using Windows XP Pro, with SP2, I want to share my drive D so that i can see it on my laptop (in another room); but I do not want other users on the network to have access to this drive. How can I do it? I do not see any permissions....just the sharing and security tab when I share.
  • 0

Advertisements


#2
Game_Freak

Game_Freak

    banned

  • Banned
  • PipPipPip
  • 586 posts
Well if you want wireless sharing Im am pretty sure you will need hardware..I have a wireless network connecting three computers not sure how to connect hard-drives....It is not safe either! If one machine gets infected the other could easily be too! So watch out!
  • 0

#3
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
thanks for the fast reply; maybe my question was not so clear. I am on a home network, both LAN & wireless enables....I have drive D on my desktop; I want to share it so that I can access it from my laptop (which is in another room), but I do not want others on the network to have access to this drive too. How to retrict it?
  • 0

#4
Ryan

Ryan

    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,867 posts
Right click on the drive in My Computer, select sharing and security.
Select Share This Folder. Give it a share name and comment (if desired).
Click on the Permissions button.

While "Everyone" is selected, change click on the Deny box for Read.
Click on Add, and then type your username (yuou might have to put in the computer name and username for the laptop - i.e. CompName\UserName0 in the box.
Give yourself Full Control.

You should be all set after that. Let us know either way.

-Ryan
  • 0

#5
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
Works perfectly
Thanks a lot
  • 0

#6
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
A slight problem on follow-up. I have only "administrator" as the profile/user on the desktop. So when I entered this and the password for permissions for the D drive, it now demands from all other computers on the network for a username and password even for the Shared Folders. I checked the shared folders, and it has "everyone" with permission; I set the new permissions only for my personal drive D......does this problem occur because I do not have a second profile on the desktop? or is there something else I am missing and need to do to free up the Shared Documents for others to access without a password?
Thanks
  • 0

#7
Ryan

Ryan

    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,867 posts
Are the shared folders on the D: drive or some other drive?
  • 0

#8
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
I want to share the entire D drive. The "Shared Documents" is the default on drive C from the installation of XP.
  • 0

#9
Ryan

Ryan

    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,867 posts
Try setting the permissions the same way you did for the D drive. Its been a while since I've had to work on home networking, and since I'm at college I don't have access to a home network to try things on. If that doesn't work, I'll have another helper come and take a look
  • 0

#10
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
I checked the "Shared Documents" which is the default shared documents on my drive C, and clicked Sharing and looked at permissions -- the permissions for this Shared Documents folder is "Everyone". When I log on as Administrator to my desktop, I need to put in my password -- the administrator account is password protected. Perhaps this influences everything else on the computer too? But if the Administrator is not password protected, everyone else on the network can see and access my shared drive D. If you can get more help, much appreciated.
  • 0

#11
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
is it possible to maek the drive D a hidden share? If so, I may not need to keep the password protection. But how to access a hidden share from my laptop to the desktop?
  • 0

#12
Ryan

Ryan

    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,867 posts
what happens when you add the other users CompName\UserName and configure them for read/write access in the Shared Folder?
  • 0

#13
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
I have found that the simplest way for me is to make my extra drive D a hidden shared drive; and then no one else on the network sees it. But I can access it from any network computer (e.g., my own laptop in another room) by putting in the run command \\computer_name\hidden_shared_drive_name

It seems to work well, so far no problem.

And i then do not need to have the entire desktop password protected.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP